loading
 
OCR is not working on my machine or I'm doing something wrong?
Pablo from Argentina  [2 posts]
2 years
Hi Guys, greeting from Argentina.

From several days ago I'm trying to work with OCR module, unfortunately with no results.



I was trying to do ocr from this image but nothing happens (code 39 barcode is working OK so I can discard camera problems or something else).

I was reading an old post http://www.roborealm.com/forum/index.php?thread_id=5450 that claims OCR only works in Administrator mode, so I tried to run roborealm both admin and NOT admin, but nothing happens.

OCR module Configuration is set to default values.

So, my question is the title of post: OCR is not working on my machine or I'm doing something wrong?

Regards.

Steven Gentner from United States  [1371 posts] 2 years
White is on, black is off ... other apps will switch this logic so it can get confusing.

In other words, the OCR module looks for white things to be letters and will ignore black things. So to quickly correct your issue just add a negative module before the OCR module. You may want to segment the letters better than just that so using an Adaptive Threshold module is normally recommended. See the attached robofile with your image in it to see the desired effect.

STeven.
program.robo
Pablo from Argentina  [2 posts] 2 years
Excellent STeven, It Worked great. I undersood exacty the opposite about B/W :(

Thanks and regards.

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index