loading
 
Quickcam Orbit AF
Keerax from United States  [9 posts]
9 years
Why can I not set my camera to broadcast in less than 100% zoom?  At 50% I get the entire field of vision of my camera but when it broadcasts it automatically switches to 100% and I have no way of changing it that I can find.

This also causes the date/time stamp to be displayed off screen of the broadcasted video.

Please help.
Anonymous 9 years
Not exactly sure why that is.

We are assuming you mean web browser broadcast right?

Couple questions:

1. What are you using to adjust the zoom at 50%? Is that the scale module? The RR dropdown menu that says zoom? The camera controls accessed from Options->Video Tag->Format?
2. What resolution are you running your camera at? 320x240? If not 320x240 you may need to enlarge the applet size in the index.html page to see more of the image.
3. Are you running any modules or is the pipeline empty?
4. Do you see something change in the RR interface that causes you to think that the scale suddenly changes? Or is this only seen in the applet?

STeven.
Keerax from United States  [9 posts] 9 years
When you first start the roborealm program there is a zoom option at the top of the screen.  I just happened to notice that when it's set at 100% it gives me the same image as when I'm broadcasting with the built in webserver. I can find no other zoom option once I've started broadcasting.

Under Options -> Video Tag -> Format, I'm not sure what size I'm outputting at because I'm not currently at home.  Will check on that when I get off work at 11.  How would I go about enlarging the applet size in the index.html page?  I'm very new at this.

Currently I believe I'm only running the Orbit module that comes with it, the date/time stamp module, and a module that was downloaded from the orbit page that lets you move the camera incrementally instead of it getting stuck and moving to the extreme directions.

I'm not noticing any changes in the RR interface when I start broadcasting but, as I said, I have noticed that the area I can see when broadcasting looks the same as when the RR zoom at the top of the program is set at 100%.  When I set that to 50% (in the main application) then I can get my full field of view.
Anonymous 9 years
Keerax,

Ok, I think I'm getting a better idea of your issue. The zoom functionality at the top of the page when set to 50% does not actually change the image pixels but just zooms in like you would in a paint program. Namely, the image size is not changed just the display is zoomed to inspect a smaller area of the image. If your issue is that the video image is too large and you need to reduce it in size such that it fits within your screen area you have a couple of possibilities to do that.

First, check the Options->Video Tab->Format button and change the Output Size drop down to a smaller size (most likely set to 640x480). This will reduce the number of pixels being sent by the camera to the computer and scale the image down in size. The applet should update also when this happens.

If you are unable to do this, we do have a scale module that you can add to the pipeline to do the same thing. Click on the Search Tab above the navigation tree and type in "scale". Double click that and once the GUI pops up type in 50% for scale .. this will reduce the image in size. Try the first technique first as that is a better solution but this one would work aswell.

Note that changing the zoom using the zoom dropdown at the top of the page from 100% to 50% would not affect the image in the applet which is by design. To change the applet you'd need to use one of the two techniques above.

STeven.
Keerax from United States  [9 posts] 9 years
Thanks Steven!  I did get my resolution sorted out so now I'm seeing the picture as I'm supposed to.  I upped the size in index.html and changed the broadcasting resolution.

Now I've got three seperate issues:

1. Is there an already built module in roborealm that would allow my orbit camera to use its microphone and broadcast sound through the same java application that's broadcasting the video?

2. My video is acting a little jumpy when I check it on other computers.  If I check the localhost on the broadcasting computer the video looks fine but if I check it on a second computer on my network the video will glitch every so often and looks like it's trying to jump to the left.  Any ideas?

3. I've been using the module listed at the bottom of this page:
http://www.roborealm.com/tutorial/internet_camera/slide010.php
It was working fine until yesterday.  Now, with that loaded the camera won't move when I send it the command to (with the buttons or the cursor keys) and it gives me an error message, "error (27) invalid 'exit' statement" when I check the properties of the vb_script. I've already tried re-downloading it and starting fresh with roborealm and it still gives me the same problem.

Keerax from United States  [9 posts] 9 years
Also, my video doesn't always show up when I check the index.html page.  I would say it loads properly about 1 in 3 times...
Keerax from United States  [9 posts] 9 years
I hate to bump my thread back up but I do need help with this setup, as my girlfriend's father has hired me to hook up some webcams in his house this weekend while he's out of state.

All I really need is the index.html page to work consistently and to get the incremental movement working again.  Everything else is gravy.

Thanks!
Anonymous 9 years
Keera,

1. Unfortunately RoboRealm does not work with sound for now, just video. You might need to check with other internet streaming software if you need audio to be transmitted.

2. Hmm, sounds like you might have a noisy network. If the localhost scenario is working ok I would suspect that something else in your network might be causing a slight hiccup. I don't think we really understand what you mean when you say the video "jumps" to the left. Perhaps if this looks like a distorted video you might check the compression settings of RoboRealm to see if that helps (also in the webserver tab). Plus, try to see if when you access the video from more than one computer if the problem gets worse or stays the same.

3. There was a typo introduced in that module. We've corrected it. You can either download it again or just surround your current routine with

Sub main()

... your stuff ...

end Sub

main()

Basically the exit Sub is trying to exit a subroutine call that it is not in. The above will fix that.

Perhaps if you have the video online through the internet we can see those irregular behaviors aswell? This might help us understand what is going on.

STeven.
Keerax from United States  [9 posts] 9 years
I figured out why the video wasn't showing in the browser.  Something about the color/lighting of my room is messing it up.

Situation 1:
Lights are on but the camera is not pointed directly at any of them.  The video won't work but you can still move the camera with the controls so I know it's connected.

Situation 2:
I point the camera directly at the light and my video starts working again (I can see the fan blades moving.)  If I move it back off of the light source my video freezes again.

Situation 3:
Lights off completely.  The light from my monitor is apparently bright enough to keep the video streaming properly.

Do you think this is a driver issue with the camera or an issue with RR?  Keeping in mind the camera works fine when I use the software that came with it.
Keerax from United States  [9 posts] 9 years
Just some more info.  If I turn the brightness setting on the camera rediculously high with the same conditions as situation 1 above then the camera starts being visible in the index.html page.
Keerax from United States  [9 posts] 9 years
Got it sorted and it all works very nicely.  Thanks for putting up with me and making such a good program free!
Anonymous 9 years
So what did the problem turn out to be? Some interesting lighting setting? Or just a flakey connection?

STeven.
Keerax from United States  [9 posts] 9 years
The problem was something about the low level of lighting.  If I put it to an extreme (dark or bright) the camera would broadcast fine.  Even the jumping video has quit.  But leaving the room lit with only my fan light so that the light levels were middling, the camera would not broadcast.

I actually fixed it by accident.  I had the brightness on the cam turned up really high and someone who was testing my cam pointed it right at the light on the fan and left it there because they're an idiot.  After that the cam started working properly (after I checked to make sure it didn't suffer any permanent damage.)

On a side note, does the video broadcast on a different port than the commands to move it?  If I'm on campus I can't see the video which makes me think they have a port blocked but I can sign into the page and move the camera around (checking that with logmein.com).  Anyone not on the campus network can see the video.

Just for testing purposes:
http://keerax.dyndns.org:8080

Lemme know what you think.
Anonymous 9 years
Keerax,

Note that you could construct a routine that once the camera is left idle you could move it away from anything bright. It find the darkest spot on the image and move the camera in that direction. That would solve the camera burn issue.

The key commands and buttons are sent from the browser using the same port number as the video. RR only supports one web port. Not sure why you would not see the video. Most likely your campus has disabled or not installed Java applet abilities in the browser. Doesn't sound like a firewall issue.

STeven.

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index