loading
 
COG, overlay
GruzdevF from Russia  [7 posts]
10 years
Hello,
in module Center of Gravity there is such function: "overlay graphics on source image"
at me it works only if I use jpg pictures or video from a local file.
if I acquired video via the cam the screen remains black.

is this normal?
Anonymous 10 years
Gruzdev,

No that does not sound normal. What type of video source are you using? An IP Camera? or a USB camera?

What video image size are you acquiring at?

STeven.
Anonymous 10 years
I use Pinnacle PCTV analog PCI TV tuner as the capture device
and the simply cam with the PAL output(real cam or video output from NIKON coolpix)

image size any, 640x480 320x240 all of them not shown after COG filter(without COG filter anything look well)

I can send you other system info and version of any software on My pc
if it could help to solv this probem.


[sorry for My bad english, at this moment no translator around =)]
Pinnacle PCTV
Anonymous
10 years
Gruzdev,

Unfortunately we have had a couple of others users report issues with the Pinnacle PCTV hardware. It appears that other programs that use DirectX including AMCap also do not work with this hardware. At this point we do not have any solutions with regards to this hardware.

Are there any other programs that you have successfully used the Pinnacle camera in? Can you try AMCap just to be sure?

Thanks,
STeven.
Anonymous 10 years
AMCap(build 109.4) work fine
and other progs to

COG and other filters work fine,
only checkbox "overlay grafics on source image" have no effect =/
Anonymous 10 years
Ok, that is good news that other filters work fine.

How are you grabbing the camera images? Are you using another module? The reason I ask is that when you are using another module like the HTTP_READ the source image is not defined and will appear black. The source image is defined as the image that is captured by RoboRealm prior to the pipeline beginning execution. If there is no image at the beginning of execution (i.e. camera button is up) then the source image will be black.

If that is your case then you need to set a marker just after you grab the image. Then use the math module after the COG module to add back in that marked image. It is more complex than just clicking the checkbox in the COG interface but at least it can be done.

To better help you can you post the robo-file that you are using?

STeven.
Anonymous 10 years
Hmmmm
Im just hour ago dounload updated driver fo my TV Tuner and install it
and all work =) (I guess I use very old driver)

I can see picture and the crosshair on it after the COG filter

Anonymous 10 years
Great! Then it appears that Pinnacle has fixed the problem. Note to all other users that have this issue ... download the latest driver!

Thanks for solving this issue!

STeven.

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index