loading
 
Fiducials - 32/64 bit windows
Kresimir Majdenic from Croatia  [38 posts]
8 months
When I run Fiducial module over [Example.jpg] on 64-bit Windows 7 ... I get 3 fiducials found and "findings" are "stable" (in each and every camera frame). But, when run the same module with same settings (default settings) and same camera on 32-bit Windows XP ... number of found fiducials changes from frame to frame.

Any idea what seem to be a problem?

 

Fiducials.zip
Kresimir Majdenic from Croatia  [38 posts] 8 months
Additional testing showed that this problem is not related to Windows 32/64 bit but appears to be related to RR version.
When I try with my old personal 2.77.10 version reading is perfect and yet, when I try with latest commercial version readings are very poor.
Steven Gentner from United States  [1370 posts] 8 months
Kresimir,

Do you have an image that shows the failure? The attached image seems to work fine in the most recent RR version. Perhaps you can try upgrading so that we are testing the same version or mention which version you are using so that we can try to replicate the error situation.

Note, if you are switching between one version and the other, you may need to retrain when doing so as sometimes the file format that is created after training changes from one version to the next.

Thanks,
STeven.
Kresimir Majdenic from Croatia  [38 posts] 8 months
Please remember that I am not working with still image ... I am working with image from camera. So, reading fiducials changes from frame to frame. Reading information from image (which is actually an image of paper) depends on finding fiducials as referent points. When fiducial is not found reading of table under it is not done and results are missing.
In case you want to recreate the same situation ... print fiducials on paper (they should be aprox. 7.5mm x 7.5mm). I use A5 and 5 Mp camera.

I've experienced problem with fiducial in RR version I've downloaded only 2-3 days ago (we are talking about commercial version - I think it is 2.83.6).

I'm aware that I need to do retrain when changing versions ... but that does not solves my problem.
Steven Gentner from United States  [1370 posts] 8 months
Kresimir,

Can you confirm that the [x] High Precision checkbox is set in the latest version? I do see the lower resolution mode not detecting the first fiducial on the page. This is normally set by default and was added to increase performance in a specific situation. If you check this, you should get similar results to 2.77.10.

We'll check why the low precision mode is getting such different results as it should not differ at this fiducial size ...

STeven.
Kresimir Majdenic from Croatia  [38 posts] 8 months
Unfortunately not even "high" precision does not improves readings. I've tried everything, I've spent a lot of hours trying to play with light, applying different tresholds, installing on 32 bit and on 64 bit windows ... nothing improved readings.
Only by pure luck I've tried the same fiducial readings with my old version with personal licence and it worked perfectly. Readings are stable under almost any lighting conditions.

Is it possible to give me access to the same version as my personal license is but in commercial version (before you've made changes into fiducial module)?
I have no special requirements (no new stuff after that version).
Kresimir Majdenic from Croatia  [38 posts] 8 months
Have a commercial application and need to solve that problem asap ...have you considered possibility of giving access to older commercial version?
Steven Gentner from United States  [1370 posts] 8 months
Kresimir,

Its mentioned in the FAQ. You can always download previous versions (up to a limit). Please see

http://www.roborealm.com/FAQ.php#q107

on how to do that.

We are currently reviewed the Fiducial module and have updated it to be inline again with your previous version. There were optimizations done to the module since your previous version which were too constraining and would cause instability. We are also looking into correcting additional issues that also exist in the previous version too but that will not be ready until tomorrow. You can download the current version to get yesterdays update which should be better than what was currently available.

STeven.
Kresimir Majdenic from Croatia  [38 posts] 8 months
It is acceptable if new version is going to be available within next 4-5 days.

Thank you very much for a support.
Steven Gentner from United States  [1370 posts] 8 months
Kresimir,

The latest improves and up and available for download. From what we can tell this should function as good (if not better) than the previous version. Can you download and give things a try?

Also, if you are able to see images that fail detection, can you unclick on the run button and then click on the snap button and save the image? That will help us track down any additional issues that our tests did not reveal. Unfortunately one needs to hold the image steady during that saving process which is not always possible.

STeven.
Kresimir Majdenic from Croatia  [38 posts] 8 months
I've just tested and it works perfectly. Thank you.

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index