loading
 
API Server Enabled settings
Joshua Robertson from Canada  [11 posts]
1 year
Hi,

I'm having trouble with the API settings not being retained from startup to startup.

I'll open up RoboRealm and enable the API server, hit OK, and then close the application. Once I start up the application again it is no longer enabled.

I've only noticed this since upgrading to 2.80.30 from 2.80.11.

This will become problematic as my application is supposed to be unnattended so starting up roborealm and my application cannot require human intervention to enable the API server so I can connect to it.

Thanks,

Josh
Steven Gentner from United States  [260 posts] 1 year
Joshua,

That functionality still appears to work correctly in .30. What I imagine has happened is that the current install is no longer able to write its settings to the registry where that information is saved. Try running RR using right click "Run As Administrator", set the API, exit and then restart. That setting should then be saved assuming the administrator has access to that registry setting.

The alternative is to use a batch file that includes

roborealm.exe -api_port 6060

see http://www.roborealm.com/help/API.php#parameters for more info on that.

STeven.

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index