loading
 
Virtual camera shows only Roborealm logo
Jeremy from United States  [12 posts]
2 years
I'm trying to use the RR Virtual cameras. After installing the drivers, I tried to display an image through the Vcam to test it. But the only output I see, when looking at a webcam viewer, is the "Roborealm - vision for machines" logo; the same orange and white logo with a blue background that is on the website. It floats around the camera in the same way as a screensaver. Can anyone tell me what I might be doing wrong? Thanks.
Steven Gentner from United States  [1370 posts] 2 years
Jeremy,

That means that the drivers have installed correctly but just not getting any image data from RR itself.

On the Options Dialog->Virtual Camera tab do you have one of the cameras enabled (there are 4). You will also need to specify what image to send to them (normally source).

Then you will have to have RR connected to some image source (like a webcam by pressing the camera button) which should then update the virtual camera.

Also be sure to chose the right VCam from your other application as again there are 4 vcams.

If all this doesn't seem to work ... are you on a 32 bit or 64 bit system (the drivers differ).

STeven.
Jeremy from United States  [12 posts] 2 years
My OS is  Windows 8 64 bit. I've done all of the above as far as I know, except I don't know how to make sure I have 64 bit drivers installed instead of 32 bit.
Steven Gentner from United States  [1370 posts] 2 years
Jeremy,

As long as you used the button in the Virtual Camera tab to install the drivers it would have installed the right ones for your machine. I just wanted to know in case we need to test things on our side since the drivers do differ (makes no sense to check the 32 bit drivers when you have having problems with the 64 bit ones).

Can you verify that your Virtual Camera tab looks something like:



and that whatever app you are using to view the image has a selecting looking like (this from AmCap.exe):



Thanks,
STeven.
John Wood from United Kingdom  [64 posts] 2 years
Hi Steven,
I am experiencing the same problem, the installation went OK, I used Amcap and could see your attached pictures.
I have tried two cameras and also selected different Virtual cams by selecting in RR and Amcap.
I do see a very small blue square in the top right of Amcap window as seen, this is only present when RR is running...may be a clue.
My computer also runs Windows 7 64 bit.
There are no exclamation marks or issues displayed.
In the screen capture the Amcap devices Virtual Cam is selected but I could not capture the screen selection.


 
Jeremy from United States  [12 posts] 2 years
My Virtual Camera tab looks like yours in the screenshot, and also AMCap shows the multiple virtual cameras available to connect to, as shown in the other screenshot. The VCam help file says" Ensure that the Activate VCam checkbox in the Options Button->Other tab is set". I'm not sure what that means because I can find no "Activate VCam" in that tab. ( See screenshot) Could you clarify please?

 
Steven Gentner from United States  [1370 posts] 2 years
John,

The blue square indicates a permission problem with sending the image from RoboRealm to the VCam drivers. This is done using a shared memory segment which should have global permissions to read and write but perhaps not in your case (we've actually never seen this particular error).

Can you try to run RoboRealm by right clicking on RoboRealm.exe and selecting "Run As Admin" and see if that helps get the image into the vcam. If this works, we can attempt a couple changes/failovers to make this particular error more evident.

STeven.
Steven Gentner from United States  [1370 posts] 2 years
Jeremy,

Now I'm a bit confused ... is that screenshot from the version you are using?

If it is the its a bit dated and before the recent upgrade of the VCam drivers. You should probably uninstall the VCam driver from the Windows Device Manager manually, download the latest version of RR and then just press the install button in the virtual camera tab. The screenshot is from a previous version that may still have had errors esp. in a 64 bit environment due to unsigned drivers. The drivers are now signed and validated to work on Win7 64 and 32 bit systems.

The previous version also only had one camera so there should be quite a bit of different in the screenshot you posted and the one I posted ... plus you should not have seen more than on RR vcam in any other apps webcam drivers.

It may also be the case that you had installed the latest drivers but are attempting to use an older version of RR to populate the image. That would not work due to the recent upgrade of the VCam drivers to support more than one VCam.

STeven.
Jeremy from United States  [12 posts] 2 years
Apologies for using an old version to provide an example of a problem with the current version - very confusing indeed! I have done as you said on uninstalling the drivers, but with the same results as before. I think there is something wrong with my computer but I don't know what it is.

Please note from the screenshot I am now using the latest version. Should I be seeing an "Activate VCam" checkbox in the "Other" tab as mentioned in the help file? Or do those instructions refer to an older version?

Sometimes the  error message shown in the screenshot will pop up; I am hopeful this might give you a clue as to what it is about my system configuration that may make it incompatible with VCam.

Thanks.

   
John Wood from United Kingdom  [64 posts] 2 years
Hi Steven,
I did as you suggested and ran RR as the Administrator but still exactly the same with the small blue box.

When you mentioned "I should  be seeing an Activate VCam" checkbox in the "Other" tab.
If I open the "Other" tab I I do not see anything relating to "Activate Vcam check box", should I?
Anything else that I may try?
Cheers
John
Steven Gentner from United States  [1370 posts] 2 years
John & Jeremy

Please ignore any mention of the Activate VCcam checkbox in the Other tab. This was only in the old version and has been superseded by the Virtual Camera tab since it was not possible to put the install button and 4 vcam activates in the Other tab. If you DO see that in the Other tab ... then you are using an old version and should upgrade.

We were able to replicate John's issue (was a permissions issue) and have added a workaround. This may or may not help Jeremy's situation.

You will need to update the drivers. The best way to do this is to proceed to your Win Device Manager via the Control Panel. Expand on Sound, Video and Game controllers and right click on each of the RR VCam's and select uninstall. You can delete the driver file if it asks you for that.

Then download the latest version of RR, install over your current install and then proceed to the Virtual Camera tab and press the install button.

Once this returns (can take a while) select the Virtual Camera #1 checkbox and select Source from the dropdown. Press ok and ensure that the main image in RR is being updated (i.e. you see a live image). Then proceed to something like Amcap and select RR VCam (without any number) and see if that shows you the same image in RR.

This route works on Win8.1 with the latest version.

STeven.


John Wood from United Kingdom  [64 posts] 2 years
Hi Steven,
Well done, all is now working, thanks for your normal speedy response, much appreciated.
John

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index