loading
 
AVM Navigator new update bug
wongfeirang from Malaysia  [26 posts]
2 years
Recently, I have update my RR with the latest version (2.72.10). I have try to run my AVM Navigator program on my RR but unfortunately the program did not work. Then, I tried it using the basic AVM program that consist of Button Interface to control the NV_FORWARD, NV_BACKWARDS, NV_LEFT, NV_RIGHT by set those variable to -1. I noticed that when I click the button and released it, the command become latch or hold and cannot be clear. This behavior did not occur on previous version of RR. Please help me to solve this problem.
Thanks

Best Regards:
wongfeirang
program.robo
wongfeirang from Malaysia  [26 posts] 2 years
Any idea to solve this issue??
Steven Gentner from United States  [1370 posts] 2 years
Wongfeirang,

Sorry for the delay in responding to this. We were checking previous RR versions (by appending a v=X.Y.Z to the download url) but not getting any different behavior of the attached file. As this is a 3rd party module it takes us a bit longer to determine issues.

Based on your description, I think you have the wrong mode set in the AVM module. You want to set it to Marker mode to have it respond to the buttons correctly. The mode that you have it in is meant after training to run the robot through the same route. The fact that the module does indeed seem to respond to the variables is perhaps a mistake and just a side effect of the display.

STeven.
wongfeirang from Malaysia  [26 posts] 2 years
Did you tested using my attached file?? I tried with the basic RR program that using button interface to move the robot forward, backward and so on. This button did not hold when I released it on previous RR version. With the new version the display of forward, backward was hold. I have choosed the right mode..
Steven Gentner from United States  [1370 posts] 2 years
Yes, we did test using your file. We found the same behaviour all the way back to 2.66 and then stopped. Were you using a version earlier than that? Perhaps you can let us know what version you were using?

Note, we also checked the AVM code. In the mode that you selected it will NOT clear the buttons after being set. You have to switch to the Marker mode in order for the buttons to clear.

STeven.
wongfeirang from Malaysia  [26 posts] 2 years
I had tried on nova gate mode..I do not remember which version I had tested. But when using the arrow key on keyboard, the display rectangle is cleared when I released the arrow key(nova gate mode). How can I do this by using NV_FORWARD, NV_BACKWARDS and so on? I want to control from external application.

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index