loading
 
Read_HTTP Timeout
CubaMadre from Germany  [12 posts]
4 years
Hi STeven,

the 'Read_Http' command fails sometimes for some seconds on all connections. It looks like there is an inhouse network problem, otherwise I have no explanation why this happens at the same time with different processes and cams (see the I/O gaps on the attached screenshot). But to minimize the failure rate it would be helpful to increase the HTTP timeout, unfortunately it is currently not possible to change this modul setting.

What happens when the read fails, will the rest of the pipeline processed anyway? If yes (makes no sense IMO), then it would be nice to change this behaviour by an option. In addition there should be a way to inform the application about the read failure, e.g. by setting a system variable (HTTP_Read_Error of type integer?).

Thanks in advance,
CubaMadre;

 
Steven Gentner from United States  [1370 posts] 4 years
Cuba,

We've added a timeout in the latest version. Note that this number is in milliseconds.

Also, a SYSTEM_ERROR was already being set to "Http Read Timeout" when a timeout occurs.

When an error does occur the rest of the pipeline IS executed as there could be other modules that require service. If you don't want this behavior, use an IF statement module to check SYSTEM_ERROR just after the HTTP module and surround the rest of the pipeline in that statement.

STeven.

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index