loading
 
RR keeps crashing, no historogram, out-of-memory error / win7 pro 64bit
Tomasz from Germany  [20 posts]
4 years
Hi,
after an long search I found your software which is really great and will work well for my application.
So I downloaded the demo and I'm trying to use it but it keeps crashing every time I try to use the Thershold module.
I most modules where historogram is displayed I don't actually see it and they often also crash.
The RR crashes or hangs, sometimes with error box "out of memory".
Sometimes it's just not reacting anymore.

After killing RR from Task Manager and restarting it with "ctrl" key pressed and reloading the saved .robo file it happend often that moduels were lost from processing pipeline... (scarry!!!!)

I run Win 7 Pro 64bit
on a i7 cad laptop with 8GB RAM.

I actually consider using RR for commecial application but I need to have this issue solved first. I'd really appreciate your help.

PS - you got from me bunch of emails and error reports.
Steven Gentner from United States  [1371 posts] 4 years
Tomasz,

thanks for your emails and error reports. Give us a bit to check them out and see if we can find the issue. Most likely we will add some additional tests to see if we can focus down on where the issue is happening. We do test on exactly that same machine configuration (but 6 Meg instead of 8) so we hope to be able to replicate the error in some way.

Restarting with the CTRL key press should no load up any modules in the pipeline ... it is used to reset RR in case it loads in a module causing problems .. which is exactly your case.

In one of your other emails you mention a weird latency in all applications. While this may not be directly related to the problem, what "Windows Experiance Index" do you see (Start button->Control Panel->System->Rating) as that may help to indicate what may be slowing down your system. With an i7 at 8Mem things should be very zippy. Perhaps your harddrive may be starting to fail?

We'll get back to you in a couple hours.

Thanks!
STeven.
Tomasz from Germany  [20 posts] 4 years
Regarding the Ctrl key option:
I started the RR with ctrl to clear the pipline and after that opened the saved .robo file which had the module missing.
In other words: I started fresh new file, added some modules, saved the .robo file, and added Thershold - RR crashed.

Started the RR with ctrl and loaded the previously saved .robo - this is when modules were missing.

I also tried out all the troubleshoting techniques from FAQ and re-installation.

As for the hdd - I can't really tell if this is hdd issue as actually this wierd latency started just now - after the first RR crash. This pc is rather new and I would not except any major issues - HDD health status is "good".

Windows experience index is:
CPU - 7,5
RAM - 7,6
GPU - 6,7
HDD - 5,9

Overall: 5,9

Appreciate your help! Cheers!
Steven Gentner from United States  [1371 posts] 4 years
Tomasz,

I think we found the issue. Indeed it was related to the drawing of the histogram graph in the Threshold and other modules. That was a slight buffer overrun that caused the memory routines to become faulty which caused the out of memory message you were receiving despite having gigs of memory free.

We've corrected this problem and have uploaded a fix to the site. Can you use the Options button->Download button to download the latest version and see if this behaves better for you.

Thanks for your patience in this.
STeven.
Tomasz from Germany  [20 posts] 4 years
Great news!
I'll give it a try as soon as I'm back from work - in about 3 hours.

Cheers
Tomasz
Tomasz from Germany  [20 posts] 4 years
Works!
Thanks!

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index