loading
 
Cannot change Color Format for camera
Anonymous  [10 posts]
4 years
Hello,

I am trying to use a iDS UI-1241LE camera in combination with roborealm. I have got the camera working only the Color Format is not what I want. It is now default set on UYVY but I want RGB (16-32bit).

How can I change the Color format?

When I go to Options and select the camera, Video Format is greyed out. If I then hit the Camera button (to activate the camera) and go to the Options menu again, Video Format is now available. I then get the properties screen but at the Color Format all options are greyed out and UYVY is selected. Also a message is displayed: "No format changes while graph is running!". From this I understand that I can not change this while the camera is in use. But if I disable the camera I can not get access the properties screen of the camera.

Thank you in advance for any help.

Kind regards,

Marco

 
Steven Gentner from United States  [1371 posts] 4 years
Marco,

Not much choice on this since its the first we've come across this issue when changing the format. You can try the Camera_Properties module and see if that changes it. If not, then try another application that might change the format and then run RoboRealm.

STeven.
Anonymous  [10 posts] 4 years
Dear STeven,

Thank you for your response.

The camera_properties module didnt work either and RoboRealm crashed often when trying to change properties. I have decided to use the camera's SDK to write an application that takes the image/picture and load that image in RoboRealm.

Marco.

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index