loading
 
Network Table Help
Anonymous
4 years
So, this year we've decided to use RoboRealm, but we cannot seem to get the data from RoboRealm to the network tables. We have used the network_module in RoboRealm, and renamed our variables to /SmartDashboard/test, but it does not send the variables.
In addition, we cannot access any variables that the robot creates on the network table, which probably means that RoboRealm cannot even connect. I have the ip set to 10.2.93.2 and the port set as 1735.
Steven Gentner from United States  [1370 posts] 4 years
Hi,

Yes, it sounds like the PC is not connecting to the CRio. Can you try running the SmartDashboard on the same PC and see if that can connect to the CRio?

If not, you most likely have a firewall issue. You can temporarily disable it using the GUI and see if that opens up the connect.

You can also test by opening a cmd console and typing

ping 10.2.93.2

and see if that complains or replies with some short TTL which means it can see that computer.

If the connection seems to work, verify what version of network tables you are running on the CRio. If you have NOT updated the code from last year then it will not work as RR is using Network Tables 2.0 which is simpler than last years and is NOT backwards compatible. See

http://wpilib.screenstepslive.com/s/3120

on getting the newest Smartdashboard code that also uses the 2.0 version.

STeven.


Anonymous 4 years
We have tried disabling the firewall but it did not work.  We can connect to the CRio fine, since we can run/control our robot through the Driver Station and are able to view network table values sent by the robot.  
We have also tried pinging the CRio both through a direct connection and over wireless and have received replies.  
I'm fairly certain that we have updated to network tables 2.0  by running the SmartDashboard 1.0.3 installer, but I am not sure if there are any other updates that I am unaware of.  All of our other software (Netbeans, LabView, CRio image) should also be up-to-date.  
Steven Gentner from United States  [1370 posts] 4 years
We can't seem to find an obvious place to check the version number to verify if you are using 2.0 or not. So, can you confirm what date is on your SmartDashboard.jar file? It should be located in c:\Users\Your Username\sunspotfrcsdk\tools\.

Our date is Nov 11th, 2012. If your's is any earlier than that, it is most likely 1.0 as we downloaded one of the earliest available versions.

If it is 2.0 we'll send additional things to test.

STeven.

Anonymous 4 years
My date is Saturday, ‎January ‎5, ‎2013, ‏‎9:15:06 PM.  
Could there have been modifications to the client which stopped RoboRealm from working?
Steven Gentner from United States  [1370 posts] 4 years
Yes, it seems that there was a protocol version update which caused the version RR is using to be denied access to the tables. This has been fixed and uploaded on the site. If you use the same download link you will get the latest version with that fix in it. Also note that the module interface was updated to allow for a bit more room on the network tables names.

v2.48.9 has this update.

Please post again if you continue to have issues.

STeven.

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index