loading
 
Spykee example
Alan Coggins from Australia  [32 posts]
5 years
I must say first that Roborealm looks like a wonderful program. I'd buy it today if only I could get the trial version working with my Spykee but I'm not having any luck. I can control the Spykee if I just insert the module... that's fine. But as soon as I try and do any sort of control from vbscript it just seems to go haywire. I've tried various example programs and either the motors don't run, or they run continuously (it seems to jump to the min value which makes it run backwards not-stop).

Am I missing something very simple?
Anonymous 5 years
Alan,

most likely what is going on is that the Spykee needs 0 to 255 in terms of speed (with 128 being 'zero'). If you try any of the other robofiles they may not be using that range (500 to 2500 is also common). Can you include the robofile that you are trying to use with the Spykee but not having any luck?

STeven.
Alan Coggins from Australia  [32 posts] 5 years
Thanks for the reply Steven. I've tried running the sample program that is on your site (Erector_Spykee.robo) and also the one from ProfMason's site. Neither of these give any movement except a burst when first connecting. Both have speed set to 0 to 255. In the ProfMason one I can watch the motor variables changing on the VBScript window but nothing is happening with Spykee's motors.

One question... is it necessary to run it in ad hoc mode (2 beeps) to get these programs to work. I've been working in network mode (3 beeps) - maybe that's the problem?

By the way, I've now bought the program... I discovered the Arduino module! Brilliant!! I've been looking for a way to get an independent robot working with an eBox 3350MX and I reckon this program will do everything I need.
Anonymous 5 years
Alan,

You can try increasing the

rate = 10

line to something larger in the Erector_Spykee.robo VBScript module and see if that helps (perhaps 40). It is possible that with lower power batteries that 10 is just not high enough to have the robot move.

You should be ok running it either in adhoc or in network mode. Just make sure you hear the login sound that indicates a connection is made and you should be ok.

STeven.

Alan Coggins from Australia  [32 posts] 5 years
There is no setting for a rate variable in the sample program on your web site.

However, I have narrowed down the problem. I can get some movement, but I need to set the motor speed to >199 or less than 100. It doesn't move at all for any motor speeds in the range 100 to 199. I have attached the simple test  program I am using.

That explains why none of the sample programs work... it just won't respond to any motor speed that involves 3 digits starting in a "1". Weird. Any ideas?
program.robo

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index