loading
 
boe bot serial connection
JW from United States  [5 posts]
6 years
i am trying to get robot relm to control the boe bot through the usb connection i changed the rx to a value of 16 and i cant seem to get the connection to work.do i need to change anything else in the bs2 code? also what baud rate should i try on the robot relm display? frustrating.....
Anonymous 6 years
Unverified but have you tried

RX = 16
TX = 0

and change the 84 in SERIN to 16468 which means 9600 baud, no parity, 8 data bits, and 1 stop bit direct connection.

RR module should also have 9600 baud.

STeven.
Anonymous 6 years
Jeff,

We found the issue to the problem. In a direct connection the BoeBot will hardware echo anything sent to it. The module was note set to deal with this situation and would not understand its own echo. The BoeBotControl.bs2 has been updated to send back a new sync char which the module now looks for and can auto detect the hardware echo.

We were correct, just change the pins to both 16 and it will work fine ... assuming you deal with the echo correctly. Note that the baud number stays the same.

See 2.42.31 for this update. And also download

http://www.roborealm.com/downloads/BoeBotControl.bs2

and install again as its been changed.

STeven.
JW from United States  [5 posts] 6 years
i tried the new values with no results, i then tried changing the baud rate to 9600 on rr and 16468 in the bs2 program for serin and serout. with no results.
Anonymous 6 years
Did you download a new version of RR?

Did you download the bs2 app again and install that?

STeven.
Sean from United States  [4 posts] 5 years
I am working with getting a boe bot into roborealm so it can be controlled solely with roborealm.  I have the whisker set up breadboarded into the boe bot. Is that all i need or is there more to be set up?  I also have fed in to script listed above and changed the few values that needed to be changed but Roborealm is still not seeing it.  What else should i try to get it to work? * note: i do not have a BT for the boebot so i need to get it as a wired connection.*
Anonymous 5 years
Sean,

Can you verify:

1. Ensure that you have exited the Parallax BS2 programming environment ... this ensures that the COM port is freed up.

2. You have the right COM port selected. If you are using a USB to serial cable this will probably not be COM1 by default.

3. You have the right baud rate set. 9600 for the current BS2 file mentioned above.

4. What error messages are you seeing if any.

5. What modifications to the BS2 file mentioned above did you make?

STeven.
Sean from United States  [4 posts] 5 years
STeven,

1. Exiting the Parallax program helped...i did not know i had to do that.
2. I changed the RX and TX values to what was stated above, 16 and 0 respectivly under the direct connection section.  I also changed the SEROUT TX value from 84 to 16468.
3. I am not seeing any error messages after i put in the com port and baud rate in the drop down.
4. The manuever buttons work but the motor values do not work.  I know to label the whiskers as left/right_whiskers but what do i label the motors with?

Thank you
- Sean
Anonymous 5 years
Sean,

The motors would be labeled according to how you want them to move.

If you move the motor sliders do the motors work? If the maneuver works then the sliders should work too.

What is the ultimate goal for the project? That will indicate what goes in the motor variable fields. For example, have a look at the other tutorials on controlling the Create or Lego NXT or Occulus, etc. They are all examples on how to use those motor value fields.

STeven.
Sean from United States  [4 posts] 5 years
STeven,

No the motor sliders to not work.  The ultimate goal is to hook up a camera to a Boe Bot and hook it in to roborealm...sort of like a little robot.  I want to then set up objects and program the boe bot to turn or what ever is need with whatever it sees.

Sean

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index