loading
 
problem with lego nxt example
kiran from India  [1 posts]
10 years
hello sir ,

      there is a problem in running the example (lego ) . every time i run , only      " 0 " is displayed in my lego .  even though i had changed the COG_Y values from (150 to 350 )  it is moving only backwards . i am using the 2.37.16 trial version .   i am attaching my files , please see it and reply me .

thanking you .

kiran .
lego_example.zip
Anonymous 10 years
Kiran,

We are getting the number to change from 0 when the NXT is connected via USB (easiest and quickest way to get a connection) with all your files without any modification. Perhaps you can try quickly when the NXT is connected via USB to see if anything is different.

STeven.
Anonymous 10 years
I am having the same issue. I can communicate with the brick by USB as well as by BT, but the only thing I can do is to move the motors. I am unable to send or receive messages to and from the brick. With the above sample programs, the display on the brick reads 0 no matter what. I've tried to change the input type but that did not seem to change anything. Any other suggestions?
Anonymous 10 years
Are you running the latest version of RR?

I assume you are using the above file without modification?

STeven.
Anonymous 10 years
Thanks for your reply!

I just downloaded the latest version of RR and the result is interesting. When using the above file without modification, I now can get a partial reading of the sent variable on the NXT display. The digit "0" is displaying constantly on the NXT and directly next to it the changing variable (cog_y) less the first digit. In other words, If the cog_y being sent is 153 then 256 then 52 then 5, the reading on the NXT Display will be 053, 056, 02, 0. The 0 is constant with the rest of the digits changing. It seems that the 0 is overlapping what should be the first digit of the variable sent. As per the sending of variables from the NXT to RR, still nothing. When I watch the message_from_nxt variable (watch variables module) on RR, it empty, as if it's not receiving anything.
Anonymous 10 years
After experimenting further, I realized that the receive block will only work if it was created on an older version of the nxt-g software (The block appears with an exclamation mark in it). If the same block is created on the new version, the communication seems to fail. I assume it has something to do with the fact that the NXT 2.0 software uses Floating Point operations whereas earlier versions use Integer operations.
Zachary Lim from Malaysia  [12 posts] 9 years
Hi Anonymous,

Please refer to my thread, if you haven't already found the problem to the NXT displaying a zero in front of the value.

http://www.roborealm.com/forum/index.php?thread_id=4470

It seems that the message sending is so fast that the NXT is juggling between 0 and the actual value of the number. In my case, I looked closely at the NXT screen and found the 0 to be flickering, so I reprogrammed the program on the NXT to receive the message only once, and the actual value was displayed. It must be due to the refresh rate of the message-sending.

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index