loading
 
Arduino 2560
Chris from United States  [2 posts]
6 years
Im working on a project to track an object, i can get the software to track an object but it will not relate the movements to the servos. I am using an Arduino Mega 2560. The sketch i am using is the one straight from the roborealm website. Any help is greatly appreciated.
Anonymous 6 years
Can you supply the robofile that you are using?

Do you know if the servo works?

Do you know that the Mega works?

Do you know if the PC is communication at all with the Mega? I.e. can you flash a LED on command?

STeven.
Chris from United States  [2 posts] 6 years
The servos, mega, and connection work i am able to run simple sketches. For some reason i am unable to upload the robofile, when i save the file it shows a lock and does not appear when i go to upload it to here.
fred miller from United States  [72 posts] 6 years
CHRIS
this may work,disconnect the MEGA board and start roborealm,then open the arduino robo file,it should open ok,may say arduino not hook up
if freezes then problem with roborealm,if not plug in arduino and select the right port #,does  it freeze
also send robo you made without arduino hook up to Steven
Anonymous 6 years
Chris,

Are you sure you mean the robofile? Or the sketch file? Uploading the robofile to the Arduino will not do anything as robofiles do NOT run on the Arduino.

If RR is freezing on the Arduino module let it sit for a bit as if the wrong serial port is selected the application may appear very sluggish/freeze until the port is released. Wait a bit and then try to select the appropriate port.

STeven.

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index