loading
 
CCD camera and 4 channel Usb DVR
Robert from China  [6 posts]
7 years
Hello everybody,

I seen this program on the internet and thought I would give it a shot.

I first tried it out with a simple web cam, worked rather well...

So seeing that it worked well with that I wanted something a bit better to play around with.

So I purchased a Color CCD camera that outputs it's signal in Pal format.  I then connected this to a 4 channel  usb DVR device.

When I run the software that came with the usb device, I can see vidoe from the camera.  hoever, when I load up Robo realm and select the device from the drop down menu I can see no video.  I have checked all of the settings and they all seem to be fine.

any ideas ?

Thanks
Anonymous 7 years
Robert,

Most likely the DVR is using a color space format that RoboRealm does not understand. You can try selecting other pixel formats by selecting the Options Button->Video Tab->select the DVR->select format/source buttons which will bring up the DVR's driver interface. You are then looking for a dropdown that has RGB or YUV or I420, etc. Try selecting RGB as that is the most basic format and preserves color the best.

If you do not see this list please post what you do see and we can investigate what format this is. Note that many vendors use proprietary formats that may or may not be accessible by external applications to what they provide (unfortunately).

Included is an example of what that interface may look like:



STeven.


Robert from China  [6 posts] 7 years
Well, I scrapped that one out (the usb 4 channel video device).

I then purchased a Easy Capture usb 2.0 video device.

When I open this one in Roborelm and choose the Smi Grabber Device from the drop down menu, I get a black screen where the video should be...

But if I open up their video editing software first, then open up RoboRelm, I can then see the video in your program.

I'm still using the same CCD camera that outputs in PAL format.


Is there no Video capture device that I can just plug into my USB port and it will work in RoboRelm?

Thanks,

Robert

Anonymous 7 years
Robert,

Unfortunately for you we've done that many times without any issue and have not found any USB video capture device that doesn't work with RR ... seems that you just have the luck!

Based on your description it is most likely that the application that you first open sets the camera in such a way that it then works with RR. This can be as simple as setting the brightness so that something can be seen. When you do see the black screen in RR have you tried to look through the options button->video tab->Source and format buttons to see if there is something that is not set that should be? Perhaps the auto-exposure or auto-lighting is not set and causes the camera to start with very low or no light and thus causes a black screen. RoboRealm tries not to change any setting unless specified to in case of these kinds of situations.

I don't suppose you get any error messages from RoboRealm?

STeven.

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index