loading
 
Username / Password Issue
DeCePTioN from United States  [6 posts]
9 years
Hello,  

I have installed the latest Roborealm v1.8.24.0.  When trying to connect to the spykee robot I continue to get a "Invalid username/password combination!" message.  When I did a network sniff of what is going on I see the following (data is view in hex):  

00000000  50 4b 0a 00 0e                                   PK...
00000005  05                                               .
00000006  61 64 6d 69 6e                                   admin
0000000B  04                                               .
0000000C  74 65 6d 70                                      temp
                                                                              00000000  50 4b 0b 00 02 00 01                             PK.....

I have noticed something different though from when I connect to the bot using the Spykee software that is from spykee's web site:

00000000  50 4b 0a 00 0b                                   PK...
00000005  05 61 64 6d 69 6e 04 74  65 6d 70                .admin.t emp

Using the origional spykee software it uses 50 4b 0a 00 0b where as roborealm uses 50 4b 0a 00 0e.  Is this why I cannot connect?  And am I correct to say that the response from the bot is that it is busy or currently in use?  I've rebooted the bot and this didn't change anything and the origional spykee software works just fine still but with roborealm I am unable to connect without getting pass the username password issue.  Please help.  Thanks.
Anonymous 9 years
Deception,

As mentioned in another thread this error was fixed with 1.8.24.1 which was updated a couple hours ago. Please download the latest version and give it a try again.

Thanks for the note!
STeven.
DeCePTioN from United States  [6 posts] 9 years
Thank you Steven.  That fixed the issue.  The other issue I am having is that when I try to use the robots camera (wifi cam) it is conflicting with the camera on my laptop.  Is there a way to be able to turn off the camera on the laptop (integrated cam) in your software?  For the only options I have is Integrated camera or Microsoft WDM Image Capture.  Thanks again!

Matt
Anonymous 9 years
Yes, just untoggle the Camera button in the main RoboRealm interface. It is on by default since most people just use an attached camera. Since you are accessing the image from the Spykee this is not needed.

STeven.
DeCePTioN from United States  [6 posts] 9 years
Hello,  Thank you for getting back to me on this so quickly.  I did just that and what happens if I do that I don't see any video at all even from spykee.  What I did was go back into your program holding CTRL to reset the configuration file / registery as explained on your site and this helped to get roborealm to see spykee's camera for the time being.  I noticed though that after so long (mabey 10 to 15mins into playing around with code etc and then running the script and stopping etc, the video kind of stops working and then things become a mess.  Video tends to freeze and then sometimes load back up and then off right away.  I'm not sure why this is happening but when trying to test some code and then run the script things become quite difficult if the image isn't loading or displaying properly and roborealm gets confused.  Any suggestions on how to troubleshoot this?  Again thank you for your support.
DeCePTioN from United States  [6 posts] 9 years
I'm sorry to post this before I figured out the problem but it appears the spykee got hung up and the video stopped working.  This was found out after I tried loading spykee in the origional app.  There is something that I beleive would be a nice feature to add to the controls of spykee in roborealm.  It would be nice to be able to control the speed of how fast forward backward etc the bot it going.  Here is a network sniff of the hex information that controls this:

------------------Turbo+Up (turbo alone shows nothing in sniff)
00000029  50 4b 05 00 02                                   PK...
0000002E  64 64                                            dd
------------------------TURBO+UP=64 64

------------------Turbo+Down (turbo alone shows nothing in sniff)
00000029  50 4b 05 00 02                                   PK...
0000002E  9c 9c                                            ..
------------------------TURBO+Down=9c 9c

------------------Turbo+Right (turbo alone shows nothing in sniff)
00000029  50 4b 05 00 02                                   PK...
0000002E  64 9c                                            d.
------------------------TURBO+Right=64 9c

------------------Turbo+Left (turbo alone shows nothing in sniff)
00000029  50 4b 05 00 02                                   PK...
0000002E  9c 64                                            .d
------------------------TURBO+Left=9c 64

With that information you should be able to then tell your code that within that range etc controls the speed of the motor.  If you like I have sniffed all the current built in features of spykee and I can upload that information under the FAQ part of our site at spykeedev.freehostia.com.  It would be nice if all the current built in options are available for roborealm and with the information I have I beleive this can be done.  Let me know, thanks!
DeCePTioN from United States  [6 posts] 9 years
Another note Steve that when you create a new script through Roborealm the default for the left and right motor without any script setup is 127 for left motor and 140 for right motor.  I would suggest that these be 128 for neutral position of motors.  :)  Thanks
Anonymous 9 years
Deception,

We will look into the video issues happening after 15 minutes. Most likely it could be a memory leak or just the robot shutting down but we will investigate further.

Note that we have the turbo mode already. Right under the manual buttons there are two radio buttons for Fast and Slow. Selecting these changes the speed. It uses slower values than the default Spykee interface since when working with vision the fps will tend to want to slow things down a bit.

Note that we also added sound, battery and docking interfaces to the module yesterday (I forgot to post about it).

When you are creating a new script and inserting the Spykee module the motors should be defaulted to 128. Or it does in the most recent version. Perhaps the ones before had a slight typo that was corrected.

Thanks for all the comments!
STeven.

Anonymous from United Kingdom  [99 posts] 8 years
Yup it seems like the robot shuts down after fifteen minutes of idleness.

I just duplicated this. We just need to include something in our script that sends something to the robot over few minutes to keep the connection awake.
Anonymous 8 years
The most recent changes to the Spykee will force the motor values to be sent every couple milliseconds ... that should be enough to keep the robot occupied and not shut down. :-)

Seems to work ...

STeven.

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index