loading
 
Spkykee
Anonymous
9 years
Any plans for supporting Apykee
Anonymous 9 years
+1 for Erector Spykee support
Anonymous 9 years
?
Anonymous 9 years
Yes, we do have plans to support the Spykee but not until sometime next year (this year's robot purchase funds are gone :-(

And for that matter the Rovio is also on that list ... if anyone has a spare let us know!

STeven.
Kurt Ingleson from United Kingdom  [6 posts] 9 years
Yeah i would like to be able to control spykee using roborealm because the robot as standard doesnt come with a roam function or any autominous ffunctions reallly. Being able to use roborealm will enable me to achieve this, kewl
Anonymous 9 years
Kurt,

Thanks for the description. That's what we figured when we first saw the Spykee and approached them for a interface to RoboRealm. We should be able to purchase the robot late next month and have an interface out for that robot in the first weeks of next year.

If you'd like to help the process along try sending Spykee an email requesting RoboRealm integration. We've extended that offer to them already with no reply.

We have noticed the mention of an open source SDK. Is that something that is available now? Does it come with the kit?

STeven.
Kostas David from Greece  [4 posts] 9 years
Hello Steven!

I am very excited of Spykee and I would also like to see that is supported via Roborealm. Some information:

1) Now Amazon.co.uk sells spykee for 99pounds, which is 110euros approximately.

2) There is no SDK for Spykee yet and I am afraid that they will not publish soon, or not at all!

3) We are making a serious try on spykeedev.freehostia.com trying to control spykee by analyzing the buffers it trades with the PC. There are some info on FAQ about some of spykee's commands and there is also an application that Jimfx developed including these commands etc. Have a look if you want!

Is it true that during the first weeks of the next year Roborealm will support spykee? It would be wonderful!

Thanks for your time

Kostas
Anonymous 9 years
Kostas and others,

Spykee control module just launched ... enjoy!

v1.8.24.0

STeven.
Kostas David from Greece  [4 posts] 9 years
When running roborealm the folloing error box is popped:

Could not find the file ScriptSite.dll! Please place in the c:\winnt\system32 or c:\windows\system32 folder. You will find the ScriptSite.dll in the RoboRealm folder.                          

The file is placed both in system32 folder and winnt folder. What is happening?
Kostas David from Greece  [4 posts] 9 years
ok solved! Needed to register the dll using admin rights.
DeCePTioN from United States  [6 posts] 9 years
Hello,  

I have installed the latest Roborealm v1.8.24.0.  When trying to connect to the spykee robot I continue to get a "Invalid username/password combination!" message.  When I did a network sniff of what is going on I see the following (data is view in hex):  

00000000  50 4b 0a 00 0e                                   PK...
00000005  05                                               .
00000006  61 64 6d 69 6e                                   admin
0000000B  04                                               .
0000000C  74 65 6d 70                                      temp
                                                                              00000000  50 4b 0b 00 02 00 01                             PK.....

I have noticed something different though from when I connect to the bot using the Spykee software that is from spykee's web site:

00000000  50 4b 0a 00 0b                                   PK...
00000005  05 61 64 6d 69 6e 04 74  65 6d 70                .admin.t emp

Using the origional spykee software it uses 50 4b 0a 00 0b where as roborealm uses 50 4b 0a 00 0e.  Is this why I cannot connect?  And am I correct to say that the response from the bot is that it is busy or currently in use?  I've rebooted the bot and this didn't change anything and the origional spykee software works just fine still but with roborealm I am unable to connect without getting pass the username password issue.  Please help.  Thanks.

Anonymous 9 years
Hi steveen you can go to http://spykeedev.freehostia.com/
register and in the faq you can see the connection process of spykee
Kostas David from Greece  [4 posts] 9 years
Steven, JimFx is right. The solution to the problem of Spykee's connection is as spykeedev.freehostia.com FAQ forum.

Will you please fix it?
Anonymous 9 years
Kostas,

Ok, this has been fixed. Looks like we had the default username password length hardcoded.

JimFX,

Thanks for the network debugging and Spykee link. We will check that out and see what codes you have and if we can help add anything that we have discovered! Nice work!!

v1.8.24.1 contains these fixes

STeven.

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index