loading
 
Logitech Sphere / Orbit AF
Dennis Onstenk from Italy  [1 posts]
9 years
Hi all,
I have been following this forum and found it very useful, if way above my head. I cannot find any information regarding the setup to have a motorised webcam pan left-right and a continuous and preset manner. It 'should' be easy - but I am no programmer.

Could anyone please point me in the right direction?

So far I found that eyespyfx.com makes it very easy for users to control the webcam, but I find that half the time it is pointing at something useless.

I am looking for two possible solutions, and I am prepared to pay for a functioning script:
- I set up presets that visitors can select
- The cam pans slowly from left to right

Here is the cam: http://www.incalabria.com/Webcam-Tropea-Live.html

Thank you in advance!

Dennis Onstenk
Italy.
Anonymous 9 years
Dennis,

We have update the index.html page that comes with the RoboRealm.zip download to include both presets and auto-panning. The auto-panning is easy, just click on the auto button and the camera starts moving on its own.

To change the presets you will have to edit the index.html page and change the parameters in

    <input type="button" value="Preset #1" onclick="setVariable('preset=5,0')">

to some other values. You will have to guess at the values since the Logitech does not have absolute positioning ... they range from -20 to 20. The best way to determine a good number is through trial and error.

STeven.

NairB from United Kingdom  [41 posts] 9 years
Steven,

I downloaded this new version and also the move_orbit.robo file and I cannot seem to get "auto" or the presets to work.

I have the both the move_orbit.robo file running and the Logitech_Orbit file.

To get the left, right, up, down buttons to work I "edit" the Logitech_orbit file and se the variable to "move"

What am i doing wrong?

-NairB :(
Dave from United States  [84 posts] 9 years
Hi NairB

Was wondering if you had any luck yet with the new index file? I tried it also with no luck, though I didn't mess with it to long. Maybe I'll give it another try later on.

Dave
Anonymous 9 years
Hi Dave,

No I couldn't figure out how to get the Auto & Presets working so I have went pack to the previous version of Roborealm until Steven gets back to us. I presume you have tried it also?

-NairB
Anonymous 9 years
NairB, Dave,

You would have needed to download the new robofile from the internet tutorial. I have attached that robofile in the link below. Note that the new version of this uses "command" as the variable as apposed to move. You should not need to change the variable in the Logitech module if this robofile loads correctly. Give the below robofile and the recent index.html (which sounds like you have if you see the pan and preset buttons) then it should just work right after loading the robofile without modification.

Give the below a try and let us know how it goes.

STeven.


program.robo
NairB from United Kingdom  [41 posts] 9 years
Whoopee...it works, thanks STeven.

See it here http://mainstreetcam.webhop.net/

I have added a "center" button and cusomized it a wee bit and still it works perfectly.

Hey Dave, have you tried yours yet??

-NairB :)
Anonymous 9 years
NairB,

Very cool. The auto pan works nicely to just sit back, let the camera do its thing and check out the scenery!

STeven.
NairB from United Kingdom  [41 posts] 9 years
Sure is STeven.....Just to let you know that the "preset" values go as high as (35 or -35) on my cam and I found this will give my cam a greater "pan" sweep compared with the value (20 or -20).

I also added a RoboRealm™ link on my page as its only fair peeps see who provides this excellent software and gives you guys some recognition ;)

thanks again.

-NairB
Anonymous 9 years
NairB,

Yes, we expect that the values will range on different cameras and the best way is to experiment with them as you have done. As in a lot of these types of projects a little patient tweaking of numbers can really add a lot to the project.

Thanks for the link! Much appreciated!

STeven.
Dave from United States  [84 posts] 9 years
Hi Steven & NairB,

Yes, I was doing a little messing around this morning and "think" I got things working. Took a little bit to figure out what was going on but I think I have it.

Thanks!
Dave
NairB from United Kingdom  [41 posts] 9 years
Hi Dave,

Just seen your kitchen webcam, works great :)

I also see that your overall picture quality from this cam has improved quite a bit since you have upgraded to the new software or is it a newer cam? :)


-NairB
Dave from United States  [84 posts] 9 years
Hi NairB!

No, its the same 'ol cam. I did notice when I start RoboRealm I don't have to change the fps manually now. Before anytiime I started the prigram I'd have to reduce the fps down from 30 fps in the "options", "Video Format" controls.

Dave
Anonymous 9 years
Dave,

That's correct. We made that small change which was long overdue. Good to hear that it works for you.

STeven.
Dave from United States  [84 posts] 9 years
Hi STeven!

If you recall some time ago RoboRealm was using a high CPU usage, up as high as 30 - 50%. After doing some tweeking at that time on the computer I managed to get that number down to 10 to 20%. With the latest version and not making any changes here, the number has dropped down to 2 to 5% most of the time, though I have seen it peak as high as 10% once in awhile. So everything seems to be working pretty good, not that I put the program through its paces or anything, I just start it and as long as its working, I'm happy.

Like NairB, I'll have to add a link again on my page to your site. I had one before on both the webcam pages but through editing and changing the "index" file so many times, I kind of lost that one. I had like about seven different index files in different folders or with different names for RoboRealm trying different things to work the eay I wanted it to and in the process lost or didn't use the index file with the link on the page. After all, putting a link on a person's page isn't to much to ask for to be using free software. So I'll take care of that some time this week.

While I'm at it, I do have a question. Is there a way to add a small ftp routine in RoboRealm? This would have a timer built in so whenever the count down ( be it 30 seconds, a minute, 5 minutes, etc.) the program would ftp the image to a persons web site? Also this image could be either over written or incramented.

Although I never tried it, I'm pretty sure RoboRealm will save images to your harddrive whixch you could then use another program to upload the image. I just have this thing of running more programs then I have to when one could do the job. For all I know maybe RoboReam can already do that in some way I don't know about? Anyway's it was just a suggestion for something some time in the future.

Again thanks for such a great program!

Dave

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index