loading
 
Server automatic start
Anonymous
14 years
Hi guys, first I would like to say this is a tremendous piece of software! I remember spending months on my own vision programs and still not never coving all the areas I needed to. Roborealm removes all this effort and makes the algorithms directly available to the end program. - Its great!

My question is: I would like to use roborealm on my robot. Roborealm will automatically  launch when windows starts, but it is likely that the video feed will  be accessed on a remote computer.

Specifically what I need is for the web and network servers to start automatically when the program is run. I know these were disabled for security reasons, but is there any way to force them to ignore this? On an embedded system it is not really acceptable to have a user keep configuring the system before they use it.
Anonymous 14 years
Actually I take that back it looks liek once the web server is activated with a password and username it stays in that state..
Anonymous 14 years
Correct, on exit RoboRealm will remember its settings and startup in that mode. If you want to change that have a look at the options button and the startup tab. Yes, we do agree that requiring config each time the app is run is not very usable in an embedded system .. and that's why RoboRealm is designed the way it is ... to ensure that it works without user intervention. Also note in the options dialogs there is a checkbox to ensure that all cameras are running before the script proceeds. This is to ensure that on startup no motor commands are sent while the camera is also starting up and perhaps blind.

Thanks for the compliments!

STeven.

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index