loading
 
RoboRealm does not see Phidgets Servos
from United States  [214 posts]
10 years
Hello,

I am trying out the latest version of RoboRealm with a Phidgets 4-servo controller.  I have the latest libraries from Phidgets and the servo controller works fine using the supplied Phidgets servo control program.  However, when I bring up RoboRealm and click on Control->Servos->Phidgets I get the error:

"Unable to find a PhidgetServo!  Perhaps you need to download the drivers from http://www.phidgets.com."

I have tried plugging and unplugging the Phidgets servo controller and on different USB ports, and always get the same error message from RoboRealm.

Is there something I am missing?  I am trying all this on a Windows Vista computer.

Thanks!
patrick
from United States  [214 posts] 10 years
I just tried the same experiment on a Windows XP machine and got the same error.

--patrick

Anonymous 10 years
Patrick,

It appears that unknown to us they have updated their software. RoboRealm currently looks for the phidgets20.dll to communicate to their devices. This has been updated to phigets21.dll and thus the reason why RoboRealm no longer finds that appropriate file. We have made the needed changes to update to this version and will post the updates on the next release due out at the end of this week.

Give it a try then and let us know if you continue to have issues.

STeven.
Anonymous 10 years
Hello STeven,

Many thanks for the quick reply.  As it turns out, I still have the older Phidgets 2.0 installer and you are correct (of course!)--RoboRealm works perfectly with the older library.  So I am set to go until your next release.

Thanks again,
patrick

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index