loading
 
Image Matching Crashes
Anonymous
10 years
It seems that whenever i try to run any of the matching algorithms, RoboRealm crashes.  Is there something that i am doing wrong?  Also, is there a way to control the matching algorith via the API?
Anonymous 10 years
Kyle,

Can you include the two images that you are trying to match and the robofile that you are using? Perhaps there is something unexpected in those images that is causing the issue. Given the images and the robofile we should be able to track down the issue quite quickly.

Thanks,

STeven.
Anonymous 10 years
I figured out that the problem was that I was using the camera input and apparently roborealm dies when it has to do that.  Using just images to match works fine.  Now i am running into the problem where I don't know how to get the output from the API.  I would assume that "Image Match" would set a variable that provided the matching picture's file path, but i cannot guess it and there is no documentation that i can find on it.
Anonymous 10 years
Kyle,

The following variables are defined:

MATCH_CONFIDENCE
MATCH_NAME
MATCH_FILENAME

Note that you can always add the Statements->View Variables module to see what variable have been created.

STeven.
Anonymous 10 years
Here is a method that crashes roborealm.  I try to add a shape matching using Image1 and Image2 to match against Image3.
program.robo
Anonymous 10 years
Here are the other files...


Anonymous 10 years
Kyle,

I'm not sure the robofile came through correctly as it appears blank.

We did some testing here and got an 86% match with from Image1 with Image3 using the below robofile.

STeven.
program.robo

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index