FRC Camera Client Receives Error When Sending Parameters
Michael from United States  [4 posts]
7 year
We're having trouble getting the RoboRIO to send the camera image to RoboRealm. It worked fine last year, but for whatever reason, it refuses to connect now. Every time we turn in on, it sends this error:

Does anybody know what's going on?
Steven Gentner from United States  [273 posts] 7 year

You are not the first to mention this (there have been 3 other teams) and the conclusion we have come to is that things have changed to the point that the protocol is completely different or no longer functioning in the way it was. Instead it appears that port 80 now has taken over this functionality so that putting in should return an image when the webcam is plugged in. In that case, if you use the HTTP Read module


with that same url to grab the image.

We've mentioned this 3 times and never gotten a response from any of the teams ... so does that mean it works? We're not sure. We don't get supplied a roboRio for this testing so we have to rely on team feedback to know if a problem has been actually resolved. So give that a try and if it works we'd really appreciate a quick confirmation.

Michael from United States  [4 posts] 7 year
It doesn't seem to work. I put in the IP for the router but nothing happened. At least there wasn't an annoying error message.

Should I pick a camera from the dropdown? The one we have is a Microsoft LifeCam HD-3000, which isn't there.
Tell me what I should do, and thanks for your speedy reply!
Steven Gentner from United States  [273 posts] 7 year
You will not see the camera in the dropdown since the HD-3000 is a webcam and NOT and IP camera. We were thinking that the roboRIO does make it into an IP camera but apparently this is not the case or has not been enabled.

You can also try typing that ip address into Chrome/Firefox/IE to see if that does anything too. According to your results it shouldn't since that module makes the same request as a browser does. Perhaps this just doesn't work or requires something else to be enabled. Again, as we don't have this system to test on we are somewhat guessing at what the issues might be.

Do you know if you or someone on your team has added any code to enable the CameraServer?For example, have you reviewed


and if not you can add those functions and then return back to the FRC_CameraServer module in RR to try with that route again.

As RR can connect to the camera directly, having an onboard netbook and plugging the camear directly into that will solve this issue and reduce network latency (big issue). In this case pressing the Camera button will just connect to the webcam and start showing its images.

Otherwise, I'm not sure what else to test/enable/add.

Michael from United States  [4 posts] 7 year
We have a single line of code in our test program:


This gets the camera to show up in the Driver Station, but RoboRealm is still having the same issue. Do you think we might be using the wrong IP/port? Or maybe FIRST changed something with their library that's messing it up? I feel like I've tried everything at this point, and nothing wants to cooperate. It doesn't help that there's little to no documentation I can find about the Camera Server for this year. I wish there was better communication with all this, instead of you not having a RoboRIO, and us not knowing what to do. C'est la vie I guess.
Steven Gentner from United States  [1446 posts] 7 year
That one line should do it ... lower down they explain what this does and instead use 1181 which is different from the default of previous years 1180. So that might be worth a quick try to see if they incremented the port number. I.e. change the port from 1180 to 1181 in the FRC_CameraClient RR module.

Yes, more documentation would be great ... that's one of the reasons we have started instead to recommend RoboSight (http://www.robosight.com/) which is an all included solution and only sends its results to network tables. Don't need to worry about image transfer, slow network delays, transmission lags, etc.

Anonymous 7 year
1181 doesn't seem to work either. From other forum posts, it seems the LifeCam is causing everyone trouble, so we're considering getting an axis camera, or possibly RoboSight as you recommended. Thanks for all your help, even though FIRST seems to have screwed us over.
Michael from United States  [4 posts] 7 year

We decided to try out GRIP, and while trying to get it to work, we stumbled upon a forum post that said to use "http://roborio-TEAM-frc.local:1181/?action=stream" to get the camera. I remembered your earlier post about the Read HTTP module, so I tried that URL and the camera showed up! No errors either!

For anyone trying to get this to work, don't use the FRC Camera Client module, use the Read HTTP one and put the above URL in. Replace TEAM with your team's 4-digit team number and press Start.

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index