Run without GUI
Tim  [13 posts]
7 year
I have created a .robo program, but now I want to run the program without the GUI open, I thought I would be able to use the API, but I am struggling on how to do this. I read the API page under the Docs tab, and downloaded the example API's, but it didn't seem to show what I was looking for. Is there a way to just run the .robo program I created without opening the GUI?

Is there a Doc that I have missed on how to do this?
Steven Gentner from United States  [273 posts] 7 year
Yes, its called faceless mode. You can see that in the Options button->Faceless tab.

Note, this is ONLY available in the commercial version and NOT the personal version. So if that tab is disabled in any way you have the wrong version.

You can find documentation about this in


You can also search for faceless in


Tim  [13 posts] 7 year
Hi STeven,

We bought a few Commercial versions to attempt to get something to work, if we can, we plan to purchase more, but I tried to toggle the faceless mode, but the program does not seem to run after it dissapears nor can I make it display again, I tried the ctrl+alt+R as well as the command line  the roborealm_Force_GUI.bat contained,  and neither of them will display the GUI.

As I mentioned previously, I have a working Compare_Image.robo Program that will calculate and circle the differences between images in two folder paths(Gold, Unit under test), I just want to execute the program I have created in faceless mode when a new unit under test folder is made, put that folder path and the corresponding GOLD folder path into variables, then execute the Compare_image.robo. (I have the Read Variables set up)I then want to have the program close after it has compared all of the images within the designated folders. Rinse and repeat.
How can I do this?

Thanks in advance.
Tim  [13 posts] 7 year
I guess the most important item in my question is, why can't I bring back the GUI after I toggle faceless mode on, I have to uninstall and re install software to get it back. If I don't uninstall, it errors out for a Image.dll
Steven Gentner from United States  [1446 posts] 7 year
Its possible that something on your machine (perhaps a virus protection system) is preventing the keystrokes from getting to the app to let it know to bring back the GUI. Even when you then run the RoboRealm_Force_GUI.bat that is only for new instances and not for a currently running instance.

Assuming this is true (i.e. keystrokes are not getting sent to RR) there is no way currently to get that interface back. To remedy this, we have updated the system to include two new .exe files in the RR folder:


which will send a message to ALL running RR instances to enter or exit faceless mode. This is done by sending a 0x8000 or 0x8001 message to a running application using the Windows SendMessage (you don't need to know this ... just documenting this for others).

You should then be able to switch between the modes using these programs as an alternative to the keystroke method by just running the appropriate program. As these use standard messaging between Windows applications the hope is that whatever is blocking the keystrokes at least allows these messages to go through.

You will have to download the latest version to get these two new small applications and to update RR to hear these new messages.

When you reinstall, exit the program and restart at least once. The version that runs just after an install seems not to respond to the new messaging ... perhaps that was also the reason you were having issues in the first place.

If you are still having issues with the file loading, please include your robofile (Saved RR configuration) and we can take a closer look as to what might be going wrong.

Tim  [13 posts] 7 year
It works, Thanks for solving this!!

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index