Running Roborealm
17 year
This is very basic, but i am stuck.

I downloaded the current version a couple of days ago and it worked fine. Manage to do some stuffs with my webcam and NXT.

However, yesterday when i clicked on the Roborealm icon, it just couldn't start. I checked the services and it's listed there, along with multiple instances of roborealm (depending on how many times i clicked and re-clicked the icon.

I deleted and downloaded and unzip again... same thing happened.

I downoaded into another notebook, and it worked fine there.

Any idea, anyone.

Anonymous 17 year

I just read in one of your forum entry whereby you mentioned to press CTRL and launch Roborealm. It worked!!

However, it still goes back to the same problem when CTRL not pressed.

hmmm... back to square 1.
Anonymous 17 year
Ok, it sounds like you got something in the registry that is causing the problem. We can try deleting the RoboRealm registry entry which will cause a more permanent fix than when pressing CTRL. Try this:

Click Windows START button
Select Run
Type 'regedit' without the quotes, then press return
Navigate to HKEY_CURRENT_USER->Software->RoboRealm
Right click and select delete
exit and restart RoboRealm

it should now appear like when you selected the CTRL key. If you exit and restart it should hopefully start again without any problems. Note that the settings stored in the registry are your last options. This is very convenient since you don't need to re-select the appropriate camera but can sometimes cause the program to lockup if the camera that RoboRealm was using is removed and the program restarted.

Let us know how it goes.

Anonymous 17 year
Hi STeven,

I did exactly what you suggested but it did not resolve the problem.
I rechecked and this time the Roborealm registry is not even listed, but under Task Manager the process is listed.

This happens around the same time I downloaded and installed the latest VisualBasic 2005 express Edition... anything to do with this? (FYI, I've already uninstall VB earlier, thinking that it might be the problem).

Roborealm is fantastic, I do hope you can help me narrow down the root cause. And after reading your forum, I have to say, your support is equally amazing and I admire your tenacity at resolving every issues that's thrown your way.

Thanks in advance.
Anonymous 17 year
Ok, we're still operating under the assumption that holding down the CTRL key and running RoboRealm works right?

The only other part that auto loads is the last program that you were working on. This is stored in a file called working.robo and my be in your current RoboRealm folder or somewhere else in your computer. Easiest way is to just search for working.robo systemwide using START->Search->Files and Folders. Once you find that file, just rename it or delete it to prevent RR from loading that file. Most likely you are using something in that file that is causing the issue.

Can you post that file to this forum once you've found it (last upload box)? We'd like to examine its contents and see what perhaps is causing the problem.

Once you rename/delete it you should be able to run RR again.

You've nailed it!!
17 year
You did it.
Working.robo is the root cause.
I attached the .robo after renaming it.
Thanks for a great product and a great support to go with it.

Best Regards
Anonymous 17 year

BTW, when you get to it, can you tell me what i did wrong with the robo file, so I don't do the same mistake again.

Anonymous 17 year

We tracked down the issue. It had to do with the serial connection to the NXT and was a bug in RoboRealm. The NXT module was trying to connect without allowing the interface to completely render ... thus the program would start and then try to connect instantly without rendering the main RR interface.

We have a fix and will update the website in the next couple of days. This most likely happened when your serial port changed .. perhaps you are using a virtual port that changes sometimes on reboot .. or when the NXT was off or disconnected.

Thanks very much for helping us debug this problem!
Anonymous 17 year
Indeed, in my design I 'had' to use a 1-to-4 USB hub, is this what you meant by "virtual port that changes sometimes on reboot"?

The notebook I used is chosen because its light-weight but it comes with only one USB port.

You can see why the notebook must be light here: http://www.buildingblocks.com.my/resource.html

Once again, thanks... and keep up the good work.

Anonymous 17 year
WOW, that's a very cool project you have going there. We never thought that the Lego NXT could actually support a laptop! Nice design. Looks very much like the previously sold ER1 by Evolution Robotics. I bet Lego will be very interested to see this project!

The additional USB hub that you have does not cause the port to switch on reboot. It is what you plug into those ports that might. For example, if you do not have a serial COM port on your laptop and then plug in a USB to serial adapter into one of those USB ports your computer will create a virtual serial port that in fact uses a usb communication at the hardware level. Because the "serial port" is not a real hardware port the associated port (normally greater than 4 ... we've seem them go up to 30) may change for some reason (usually due to other hardware devices being plugged in). When this changes the Lego NXT module will need to be updated.

Regardless, once stable (i.e. you're not installing any other hardware) we think the port number should remain stable too so this should not be a long term problem.

Nice work! We linked to your project from our resources page cause it's just soooo cool!!

Andrew from Malaysia  [5 posts] 17 year

Thank you very much for linking my project.

Yes, it is inspired by the ER1. The platform with the notebook on it can move at a decent speed, but of course speed is not what we look for here. This design feeds the drive directly from the servos, but one can also easily build in gearing for more power.

The BB Vision Platform along with another smaller bot using RF camera will be demo'd at our local Microsoft office in May or June. I will be introducing your software there. Next thing I would like to get into is MSRS. Any advice for using MSRS, Roborealm and NXT combination?

As for the USB ports, since I already have the whole notebook attached to the paltform, I use the USB cable instead of bluetooth for NXT and it registered as COM10. It worked fine.

Anonymous 17 year

Good luck with the Demo! Should be a good show. I'm sure they will enjoy what you have to present.

As for advice for the MSRS system ... patience. It is a very powerful and complex system. If you are not very familiar with the Visual Studio line of products, C# and web services you will find it to be a steep learning curve. We'd recommend starting and playing around with the tutorials to get comfortable with the way it operates and the errors that get generated when things go wrong. For anyone interested in running PC's with robots it is a system worth spending some time with.

Let us know how the demo goes!


This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index