problem in sprkfun_mega module
Nithyananda from India  [1 posts]
8 year
Hi Steven,
         I keep encountering a problem with the spark fun mega module. Every time i open the roborealm file the pin names assigned in the servo(pwm) tab seem to be not saved, even if the file has been saved.
      Can you please provide assistance with this problem. .
                                                                                                               thank you
Steven Gentner from United States  [273 posts] 8 year

Try downloading the latest release ... the  key strokes when typing in the variable name was not being recorded correctly.

Sriprada from India  [5 posts] 7 year
Hi Steven,
The sparkfun module is still not working properly. I downloaded the latest version of software, but when i save the names of a variable in the servo tab the pins doesn't get locked and hence as the variable value changes through vbscript, there is no change seen in the servo tab. Can you please help.
Nithyananda from India  [2 posts] 7 year
Hi steven,
                  The problem doesn't seem to be solved yet....The variable names assigned in the servo pwm tab still won't get saved when we restart the roborealm file.

thank you...
Steven Gentner from United States  [1446 posts] 7 year

We were able to verify the problem but since the fix we cannot replicate the issue in either the Sparkfun_Mega or Sparkfun_Arduino module (so unless you are using a different module I think the problem is fixed).

Can you verify that you see 2.80.21 in the title bar of the RR version you are running?

What I am doing is start RR fresh, add the Arduino module, type in [test1] into the channel 1 servo PWM variable combo box, pressing ok, and then saving it as something.robo. Restart RR and reload shows the [test1] in the variable field. Do you see something different?

Sriprada from India  [5 posts] 7 year
Thanks Steven for your kind reply,
Actually the problem of variable name saving has been solved, but the actual problem is I use vbscript to send commands to this variables. Thus when I save the variable name the current value of the variable in the servo tab gets looked but when the value changes in the vbscript the variable unlocks itself and further changes in values of variable is not done as the variable in servo tab unlocks itself.Can you please help with this problem
Steven Gentner from United States  [273 posts] 7 year
What do you mean by "variable in servo tab unlocks itself"? Can you give me a use case, as described above that we can reproduce the issue? If we can't reproduce it we can't fix it.


This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index