Roborealm crashes when webserver is activated
9 year

When I start streaming from the webserver using Firefox, the image freezes frequently. I tried different settings but failed to get a reliable solution. Also roborealm itself freezes from time to time. No problems at all as long as I don't stream.
Steven Gentner from United States  [1446 posts] 9 year
Its possible that there is a bad interaction between one of the modules you are using and the webserver. Could you post the robofile (roborealm configuration) that you see this behavior on? I've tried a couple combinations but don't see the same behavior as you are describing.

Anonymous 9 year
Hello Steven

file attached.
Steven Gentner from United States  [1446 posts] 9 year
What version of RoboRealm are you running? The file appears to run fine on the most recent version and we've not heard of any web server related issues lately.

Its likely possible that something has been fixed since your version which is why we don't see the problem. We can try testing with the version that you have just to verify.

Anonymous 9 year
I purchased the latest version 2.74.2 and the problem persists. Note that I don't have any problem when I stream when my .robo program is not running.
Steven Gentner from United States  [1446 posts] 9 year
Unfortunately I'm not able to replicate the behavior you are seeing. I've tried streaming at 1280 x720 while running your robofile to both FireFox and IE. No noticeable freezing seems to happen ... at least within 5 minutes. Couple possible reasons for your issues:

1. Can you check the memory being used on your machine? I'm not sure what image size you are streaming but its possible that things are getting a bit tight which is causing momentary program freezing while memory is reallocated in other programs (once RR is running, it allocates very little memory during processing for efficiency reasons so its most likely another app that is causing the memory movement).

2. Can you giggle your webcam cable during streaming? Its possible that a momentary glitch in the USB connection is causing the program to pause while the data error sorts itself out. This would be somewhat random so its hard to track down.

3. There could still be a problem with one of the modules you are using. While I don't see any issues with your current robofile its possible that the edge_probe module is having some issues depending on the image being processed. While we've reviewed it for any obvious issues its possible that due to some image combination either it or the other modules is causing a freeze due to excessive processing. Do you notice the CPU load going up during a freeze?

4. Can you try disabling the edge_probe and/or sample_color module (using the disable button) and see if that freezing continues? This would help to isolate which module might be the cause.

At this point, I don't think the webserver is the issue since you also see the freezing in the app itself. Naturally, if the app freezes then the web interface will also freeze.

If you are also able, we can use gotomypc, teamviewer, etc. to do these tests on your machine since we're not able to replicate the issue. Please use the contact form to send us a private email so that we can set that up.


This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index