Failing to pause pipeline after waiting 10 seconds...
Stephen Hewitson from United Kingdom  [6 posts]
9 year

I have written a c# application that is based on the c# sample app that uses sockets to communicate with Roborealm.

However, occasionally I get "Failing to pause pipeline after waiting 10 seconds.", then something about continuing to wait and closing applications.

I have seen the API_COM stuff and was wondering if that was a better way of doing what I need.

All I am doing is loading roborealm faceless, applying an RGB filter, flicker filter, blob filter and getting the blob_count a number of times. Then I change characteristics of the blob filter and get blob count a number of times.

Thanks in advance,

Steven Gentner from United States  [1446 posts] 9 year

We've added an option in the Options Button->Other tab to increase that pipeline timeout to zero (disabled) or number of seconds to wait. (this is in the latest version just uploaded).

The most likely cause of this in your case is when the API wants to make a change to the pipeline it has to wait its turn before it can modify anything being processed (you cannot interrupt processing in the middle of a task). When this request is happening, the pipeline appears to take longer than 10 seconds to iterate through the pipeline at least once. This normally means that the pipeline processing is stuck. Most of the times this has to do with a bad network/serial/usb connection that some module need to work prior to continuing. That's the reason this was added ... just in case something happens you can chose to attempt to continue. Note this includes grabbing an image from a USB device!

Switching to the COM object will probably not help, it and the native C# code both use the same routines when interacting with RR.

If you want we can review your pipeline for any of these issues if you post it here. Does the timeout happen just at random or is there something to your knowledge that might be causing this delay?

Roland from South Africa  [107 posts] 9 year
Just chiming in here. I never knew that warning existed until the day I tried out a HD camera, the Microsoft lifecam. Up until then I'd only tried 640 x 480 cameras and that message never came up.

I've been wanting to upgrade the camera on my machine, but am worried that that message comes up during operation and halts the process. Is this possible, or does the message only come up during editing?

Steven Gentner from United States  [1446 posts] 9 year
It should only popup when there is an issue. If you now use the Options Button->Other tab and set the timeout to zero it will no longer popup ... but when the RR app freezes for an unknown reason you'll not know why. This was added to better inform folks as to what might be going wrong. This often happened when sometime would write a programming loop (using the Python scripting module for example) which would cease the processing and cause the app to appear unresponsive. This was often thought to be the fault of the app when in fact its just a routine programming error.

So, if you've never had a concern with this in the past the message should not popup. In fact because the programming modules now have their own checks they will popup a similar alert after 5 seconds of not returning control to the pipeline. If you have a very long processing VBscript (which if you do you should probably add some Sleep or Wait functions) that message will popup.

We will add a second timeout option specific to the programming modules too.

Dana Wright from United States  [2 posts] 9 year
I am having the same issue, and seems to be related to the Kinect Camera.  Im new to RR, and havn't used in much as of yet, but this seems to be the first issue that i have had.  Pipeline message appears, and no matter what i do it is locked up, until the next message appears, with a change in screen shot from the Kinect.
Steven Gentner from United States  [1446 posts] 9 year

If I understand you correctly then, you just have the Kinect module with no other modules in the pipeline and you are getting these messages with occasional updates of the main image from the Kinect?

If that's the case, it sounds like some other issue in terms of the connection to the Kinect is happening. Did you connect enough external power to the Kinect? Are you running any other USB device on the laptop? Do you have the laptop also plugged into main power? We found that SOME netbooks without main power attached would not run the Kinect device correctly.

This isn't so much a RR error but rather an error to let you know that some device is taking too much time to complete its operation. Before this message people would just think that RR is locked up when in fact its just waiting on an external device.

Dana Wright from United States  [2 posts] 9 year
That did it, thanks so much for the quick response.  I had 2 camera's plugged in, plus was using a lead cord.

Thanks again Steven :)

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index