RTSP video image in RoboRealm
from Mexico  [3 posts]
9 years

I am developing an autonomous mode for the FRC off-season that would have vision targeting using RoboRealm. However, the camera I'm trying to use right now is a Zavio F210A (we do have an Axis M1013, but it is being user at some other project right now and it will be available until July 13~) but I cannot seem to get the video image from the camera in RoboRealm. I've tried using HTTP, HTTP read, without any luck. I think the problem is that I shouldn't be using these HTTP* modules, as the URL to get video image from the camera, uses the RTSP protocol. The URL is rtsp:// .. I was wondering if you could help me get this camera set up so I can start working with the vision targeting.

Any help would be greatly appreciated. I look forward for your reply.

Best Regards,
Steven Gentner from United States  [1442 posts] 9 years
According to the  user manual



into your browser and you should see the camera. Then view source on that page and look for something like

which is the url that you would enter into the HTTP Read module. The 8070 is the default port for MJPEG (note this is JPEG and NOT MPEG) but it doesn't mention what the XXX.YY should be. That you'll have to find yourself.


from Mexico  [3 posts] 9 years

Thank you very much for your reply.

I've followed your suggestions. The URL is .. However I still seem not be able to get it working. I've tried with and without credentials, in either GET and POST, with Refresh Frequency set to ASAP and I still can't see the image in RR, YET camera starts and keeps blinking as if it was streaming.

Something that may help is that after trying a bit to get the image in RR, when I go to my browser, the video player says 'Too many connections'. I am the only one testing this, when I try to use in RR, I close the browser page.

Any idea?

from Mexico  [3 posts] 9 years

Forget my last post, I got it working doing a firmware update!! AWESOME! Thank you so much for your help Steven.

For user that may encounter this problem:
1. Update firmware
2. Disable RTSP and Audio codec in your camera config page
3. Disable authentication for viewer
4. In RR, use HTTP Read module and set the URL to -> <- Replace with your camera's IP
5. Method: POST
6. User and Pass: empty
7. Refresh frequency: ASAP
8. Start

And there you go! Again thanks for the support Steven, you made realize some key points for succeeding. I appreciate it very much.

Best Regards,
Steven Gentner from United States  [1442 posts] 9 years

Thanks for the detailed help.

Interesting in that the port they mention in the docs (8070) is not needed. There's nothing that actually replaces being able to play around with a device to find out what's what.

Seems like a good replacement for the Axis, we'll have to keep that in mind for next years event ... a couple teams always seem to destroy or lose their cameras and look for inexpensive replacements.


This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index