MSRDS 4 beta2 is not working with Roborealm
RoboCrats from India  [2 posts]
11 year
I tried a lot...but i was not able to interface MSRDS4 beta2(latest version) with roborealm.....i used MSRS 2008_R3 to configure it...but still it dint work
however, when I run bin\dsshost /p:50000 /t:50001 /m:"Config\Interface.manifest.xml", I get the following errors...

**  Error creating service.  Service type:http://www.roborealm.com/2008/12/interface.html [11/05/2010 11:32:59][http://midlap165.zygo.com:50000/constructor]
*** Service creation failure most common reason:
- Service contract identifier in manifest or Create request does not match Contract.Identifier
- Service references a different version of runtime assemblies
*  Manifest load complete

I'm using Windows ultimate 64bit OS and Visual Studio 2010 ultimate?doesnt roborealm support 64bit OS?
please help me out in interfacing MSRDS and Roborealm!!!
Thanks in Advance...!!!

Andrew Glowson from France  [1 posts] 11 year
I'm also experiencing the same problem...!!!
Is not there anyone? to help in solving this problem....
Please....help me out!!!
Syfy from Netherlands  [18 posts] 11 year
mabay its indeed a 64bit problem.
if you can tray a 32bit you know for sure.
if im not mistaken 64bit is not yet supported by many progs.
also is there a possibility that a 32bit prog runs slower on a 64bit os system.
please google, im not sure of this, i googled this to a while ago.
if i were you i instal 32 bit os on a old hdd and tray.

Barney from United States  [14 posts] 11 year
I am also facing this and I am using MSRDS v4 beta 2 on 32-bit Windows 7 on a Core 2 Solo.
Anonymous 11 year
Try the following download instead


As usual RDS is not backward compatible with previous code. We had to change the code and recompile to get this to work.

Barney from United States  [14 posts] 11 year
Thank you for the quick response :)
RoboCrats from India  [2 posts] 11 year
Thanks Steven!!!
Barney from United States  [14 posts] 11 year
Hi Steven,

Can you please recompile your code for interfacing with the new MSRS 4. The current code for MSRS bet2 does not seem to work with the latest release (snapshot attached).


Barney from United States  [14 posts] 11 year

Any update on this.... it appears that those using MSRDS 4 are stuck since March 3, 2012 . Please release an interface code for the MSRDS4

Anonymous 11 year

That's why we include all the source code for the MSRDS interfaces. You *can* compile them yourself if a version upgrade happens (which it does quite a lot and frequently breaks previous code).

So when you download the updated version at


note that the full source to those binary files are included as part of that download. :-)


This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index