Telnet not displaying text
S Miller from United States  [1 posts]
13 year
I have been attempting to test the API communications but keep running into issues with telnet not displaying any text after I have opened the localhost communication.

When following the API testing example I am able to open the localhost connection through >telnet localhost 6060, but once the window clears no further text will display on the screen.  If I type the cursor will move across the window, but thats it.  Nothings displayed and no further communication seems to happen.  

Any help with this would be great.  I've tried it on both windows XP and 7 and both have the same result.  
Anonymous 13 year

That's actually correct and the way that telnet works without a local echo. While you do not see any characters being printed they are actually being sent. That's why the test example has you PASTE the text into that box ... since you can't see what you are typing its easier that way.

Note, the API is NOT telnet ... but we are using telnet to show a simple example. The API is network (socket) based which is present in most languages and telnet is a simple interface to this technology. So when you use the API you are using network technology which telnet is an example program that gives you that access.

If you have a look at the API examples in the download you will see various languages that can be used to access RR via the API. Hopefully there are examples using a language that you are familiar with.


This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index