Dream Cheeky USB Missile Launcher Not Recognized
Dan from United States  [4 posts]
13 year
I have a Dream Cheeky USB missile launcher w/ webcam and RoboRealm 2.37.8 doesn't seem to recognize the device. The launcher works just fine with the software it came with. Error message reads, "Unable to find the Dream Cheeky USB missile launcher!"
Anonymous 13 year
Try using Control/DCMissle.

Works for me.
Anonymous 13 year
Try downloading


and run in a command console. It should print out all connected usb devices with their appropriate product and vendor ids. In the past we have found DC to change these numbers based on the product version. Having those numbers would then allow us to update that module for the latest version.

Currently that module checks for 4 different versions ... I guess they may have added another!

Dan from United States  [4 posts] 13 year
I ran a similar program I already had and got the following information on the Missile Launcher:

Vendor ID: 2123
Product ID: 1010

Is this compatible?
Anonymous 13 year

Can you download v2.13.9 and give things a try? That info has now been added in but they have also changed some of the button commands in the past. See what works in 2.13.9 as we may still need to change a couple numbers around.

Dan from United States  [4 posts] 13 year
I downloaded v2.13.9 but unfortunately, I continue to get the same error.
Anonymous 13 year

Once more with version 2.13.11 as we were not sure if your numbers above where base 10 or 16 (hex). We tried base 10 which appears not to work and have now switched it to base 16. Let us know if that helps.

Anonymous 13 year
     I installed the latest version and the results are different. No longer am I getting the "not found" error, however, I'm have a new problem. When I open DC_Missile, the device is still unresponsive and when I attempt to close the DC_Missile box, the RoboRealm locks up and it stops responding. Progress perhaps, but still not functioning.

Anonymous 13 year
It's been awhile since I heard anything from you guys. Is it safe to assume you can't help me out anymore?
Anonymous 13 year
Most likely DreamCheeky has changed things. Just to clarify ... do you have the older version or the newer gray with embedded webcam? We have the older one with the microsoft camera ontop which is the one we thought you were working on. Checking their website the latest gray one appears brand new and probably has upgraded internals which is why nothing is working. DC changes the programming every time they release a new version.

If you can verify this is the version you have we will see about getting one of those for testing.

Dan from United States  [4 posts] 12 year
So after a long hiatus, I'm back. To answer your question, it's an all-gray missile launcher w/ embedded webcam. Hopefully, you're able/willing to continue to troubleshoot.
joshua chavers from United States  [2 posts] 12 year
I'm having this same problem with the same launcher...any help?
Anonymous 12 year
Mine works fine.
joshua chavers from United States  [2 posts] 12 year
my camera works fine with it but i cant turn the turret with the controls in roborealm nor will it turn automatically using the motion detection, center of gravity & dc_missle.
Chris from Canada  [6 posts] 12 year
I also am having problems with the all-gray missile launcher w/embedded webcam (VID = 2123 (Hex), PID = 1010 (Hex)).  As previously reported, the DC_Missile module does not control this launcher and attempts to delete the module will cause RoboRealm to lock up.

The good news is that I was able to control the launcher through the USB_HID module using the following setup and sequences:
  Initialization Sequence:  \33\9\0\0
  Console = Hexadecimal

  Send Now:
    STOP = \2\0

Hopefully, this will give you enough information to update the DC_Missile module.


This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index