Nxt brain dead
Ross from Canada  [2 posts]
13 year

I have 6 nxt robotic kits that I bought 2 years ago and now they do not work. The battery says that it is charged but when I press the on button nothing happens or I get a screen with fuzz lines on it. when it is on there are beeps when I scroll through the menu but all I see are fuzz lines if that.  have others had this problem and what is the solution?

Anonymous 13 year

Have you tried pressing the reset button ... its a little hard to find:


Ross from Canada  [2 posts] 13 year
I tried the reset button and still nothing happens :(
 [29 posts] 13 year
You might have a continuous reset loop happening. Possibly an internal I/O short. Any chance they were exposed to moisture or water spill? I have repaired these in the past. I could look at them for you if you like. Poulsbo, Wa
Nick Matheos  [17 posts] 13 year
I had the same problem.  3 nxts went out at once.  They actually still work but the screen is dead or has lines on it.  I use a freeware program that displays the screen on my computer if I want to use them.  online they showed people repairing them but when I tried the repairs, it didnt work.
Nick Matheos  [17 posts] 13 year

i believe its nxt screen for pc and they have one for mac.

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index