Update on 2.30
13 year
Everything the same. Worked once and then Never again. The earlier versions worked once every 20-30 times. Yet, it worked every single time with the competitors drivers.  This is why I don't think the Kinect unit is bad. I have checked the task manager and it IS turning off when I tell it to. Sometimes not fast though.

Guys, I feel helpless. Is there anything I can do at THIS end to help you?


Anonymous 13 year
Can you answer the following:

1. After a complete reboot (not reinstall) does it work once and then never again?

2. Are you plugging in the Kinect and THEN running RoboRealm?

3. Do you see any error messages that popup when you do?

4. Are you loading in a previous robofile or adding in the Kinect module from scratch each time?

5. When you say worked once every 20-30 times what did that entail. Did you quit RR, restart, add in the Kinect and then just see black? Or what is the test process that you were using.

It seems to be something specific to your setup as we're not having any additional reports of issues.

Thanks for the info!
Anonymous 13 year
1=No, only worked one time with RR. Booting, rebooting, quiting, restarting over and over and over until it worked.
3= only when close
5= Quit, reboot

I am going to bring the unit back to Walmart and try to trade for another.


I will keep you posted.
Anonymous 13 year
OK, Steven, here is what I have done:

Installed and RE-installed a gzillion times. Following the directions given.
Totally wiped out, repartioned and reinstalled FRESH Windows xp Pro and RR and kinect drivers-- that is all on this unit. Not even a virus protection.

I just went to Walmart where they got a NEW shipment of Kinects in and returned my original and got a second brand new unit.

Erased all drivers and RR software.

Rebooted, installed all drivers, rebooted again.

Hooked up connect, ran RR.

Everything is the same as it was except the first time this time kenect did not run. Leds could not be controlled, no rgb picture, no 3D depth, no nothing. just a blinking green light no matter HOW I set it.

That is my report for tonight.  Sorry :-(

You guys have worked really hard. I appreciate it.

Anonymous 13 year
Good, at least things are getting consistent. That's what we want as apposed to random things working or not working.

Go ahead and download 2.30.2 and install JUST RR. No need to reboot, reinstall anything else as we want things to remain consistent for now.

1. Plug in Kinect

2. Run RR

3. Click on Options button->Other (last) tab and select Verbose RoboRealm.log file at the bottom of that interface. Then select ok. This setting will be removed the next time you start RR and is only active until you exit.

4. Click search tab, type in kinect and double click to insert that into the pipeline.

5. Once you see the black screen with the Kinect module inserted  (press ok to any errors) just exit RR.

6. Go to c:\roborealm.log and zip and post that file here. It will contain debugging info specific to the Kinect module and does not contain any private data. That will help us determine where things are going wrong for you.

Anonymous 13 year

    I tried swapping usb ports like the other gentlemen did. No soap. I am to my wits ends. I can't understand why. But, I will accept what I cannot change. If you think of ANYTHING I can do on this end, let me know.
    I was thinking about you hooking up to my computer remotely and seeing what you can find out.

Anonymous 13 year
OK, here is the LOG file.

Anonymous 13 year
I forgot to attach the log. Here it is.

RoboRealm LOG.zip
Anonymous 13 year

Thanks, that was very helpful. Can you now delete c:\RoboRealm.log, download 2.30.3 and repeat the same process? It seems that things are further than before but the depth information is just not getting sent.

Anonymous 13 year
I am sorry. I messed up my windows. It will probably be THU night before I can send this information.  It won't let me install drivers. It is asking for Windrv6 instead of iousb.sys.

Anonymous 13 year
It seems that the green blinking light is the only indication until I try to turn RR off. At that point, the little red laser comes up. As if it WANTS to work when I tell it to cut off. Weird. But, I should have you some more info Thu night. Sorry.
Anonymous 13 year
Just a clarification ... did it ask to install libusb.sys? Or iolib.sys?
Anonymous 13 year
I don't remember, but I can test it. I will let you know.

Now on 2.30.3,  here is the log.
RoboRealm TEST.zip
Anonymous 13 year
libusb.sys is what it asked for.


This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index