Plugin-Modul Error in 2.28.5
quitana from Germany  [20 posts]
13 year

Something don't works with the Plugin-Modul in Version 2.28.5.

I do the following:

1) Open RoboRealm
2) LoadImage
3) Try to use "SwapColor" Plugin. --> But nothing happends.

I tried the same with Version 2.28.6. The same error arised.

I the end I want to use my own moduls (Windows-DLLs), which I developed for version 2.5.2.

I need help. Thank you very much

quitana from Germany  [20 posts] 13 year

I just saw the version log entry, that there is a fix to the plugin framework: "Oct 25, 2010 - 2.28.6 - Fix to plugin framework."

I tried the all with version 2.28.6!!!!!

So i have another question:
I made the follwing observation:

1) (plugin) Windows-dll WORKS WELL in version 2.5.2.
2) (plugin) Windows-dll DON'T WORKS in 2.28.6.
3) The "Read_HTTP"-Module WORKS NOT WELL in version 2.5.2.
4) The "Read_HTTP"-Module  WORKS VERY WELL in version 2.28.6

So is there a chance to get a version between 2.5.2 and 28.6 in which,

1) (plugin) Windows-dll WORKS WELL
2) The "Read_HTTP"-Module  WORKS VERY WELL in version 2.28.6

Thank you very much for your anwser.

P.S.: Do you have paid/commercial help service? (Because I need help very fast)
quitana from Germany  [20 posts] 13 year

i made literal error. It should be right just like this:

So is there a chance to get a version between 2.5.2 and 2.28.6 in which,

1) (plugin) Windows-dll WORKS WELL (as in version 2.5.2)
2) The "Read_HTTP"-Module  WORKS VERY WELL (as in version 2.28.6)

EDV  [328 posts] 13 year
-= Just for statistics =-
I use RoboRealm v2.28.5.0 and it worked properly when I started SwapColor plugin (under Windows XP SP2).
quitana from Germany  [20 posts] 13 year
Our systems (tested on 4 computers):

Microsoft Windows XP
Version 2002
Service Pack 3

quitana from Germany  [20 posts] 13 year
I did another Test

- the regedit is o.k.  (see picture 1)
- after clicking on "SwapColor" the error message is: "Error - Could not load SwapColor.dll. Check that SwapColor.dll is in the same folder as the RoboRealm program.  (the SwapColor.dll is in the Plugin folder, I tried to put it in the RoboRealm folder too)  (see picture 2)
- the RoboRealm.log File shows no Errors (see picture 3)
- after trying to access the SwapColor-Plugin we get an error from every module (see picture 4)

quitana from Germany  [20 posts] 13 year
OK i've narrowed down the problem a little bit?

I have just downloaded a new 30 day free trial of RoboRealm on a new accound - and everything works fine.

But if we use our commercial license link, then it fails.

I have tried it on many different computer (xp professional sp3, xp home edition sp3, ms windows server 2003 R2 SP2)


The plugins work in the trial version 2.28.6
The plugins DON'T work in the commercial version!!!!!! 2.28.6 / 2.28.5

Thank for help.
Anonymous 13 year

Try once more to download and install the commercial version. We had a dll missing issue in the version of last two days due to an upgrade in MS compiler. This error has now been corrected but no note was made as it falls under the previous version.

Give that a quick try and see if that helps ... we will continue to investigate on our side.


Anonymous 13 year
Oh, and we tried to replicate your issue using the loadimage module and then clicking on the swapcolor module. It seems to be fine for us on all versions but there may still be an issue for some reason. We will continue to test on other machines.

When you say that adding the SwapColor module does not do anything ... do you literally mean that no error/dialog/etc. appears?

You can also try a test by placing the swapmodule.dll into the


folder which should be in the search path and should be found by RR. It is possible that the dll search path is not seeing the dll even in the RR folder.

quitana from Germany  [20 posts] 13 year
Hi Steven,

thank you for your awnser,

As soon as I'm back at work tomorrow, I will try and say what happens. Hopefully it works with 2.28.6, because we made the observation that many things work much better for us (e.g. Read_http) with this new version (in contrast to 2.5.2).

"When you say that adding the SwapColor module does not do anything ... do you literally mean that no error/dialog/etc. appears?"


If i enable the "Verbose RoboRealm.log" check box an window with the error message

"Error - Could not load SwapColor.dll. Check that SwapColor.dll is in the same folder as the RoboRealm program."

arises.  If i disable the "Verbose RoboRealm.log" check box no error window and no error message arises.


quitana from Germany  [20 posts] 13 year
Hi, i tried the following way. It was not successful.

1) Uninstall RoboRealm 2.28.6
2) New Download RoboRealm 2.28.6
3) Try to use SwapColor-Plugin -> not successful (same bad behavior as described befor)
4) Copy SwapColor.dll in c:/windows/system32/
5) Try to use SwapColor-Plugin -> not successful

Next I walked over to the nearby university, because I knew that they have computer with Microsoft Vista Business.

6) So I Uninstalled our commercial License from our company computer
7) Install RoboRealm 2.28.6
8) Try to use SwapColor-Plugin -> not successful -- > an error occured (see "vista_error.jpg")
9) Copy SwapColor.dll in c:/windows/system32/ -> not succesful -- > an error occured (see see "vista_error.jpg")
10) Uninstall commercial license on university computer
11) Install trial version on university computers -> IT WORKS FINE! (see "trial_version_works.png")
12) I switch between the commercial and the trial license --> always the same behavior --> trial ok --> commercial bad.

I noticed that the commercial setup file is a lot smaller than the trial setup file (see "setup_files.png"). Can it be that something was not compiled in the commercial version?

quitana from Germany  [20 posts] 13 year
On the last three pictures you see:

left: The error message after clicking on SwapColor-Plugin AND then clicking on an other module. (Swapcolor-Plugin don't works. After clicking on other Vista breaks down)

middle: All runs well with Swapcolor (and i think with our own Plugins also) when using the trial version.

right: Both setup files have different size. Trial version("Setup_RoboRealm(2)") has a size of 4.158 KB, while the commercial setup file has a size of 3.703 KB. Is that an hint of not supplied DLLs (or other files) in the commercial version??

Anonymous 13 year

Thanks for the image. Unfortunately we have not been able to replicate the error on any of our test machines including win98, win200, winxp, vista and win7. Everything appears ok.

Can you download the latest version and check the verbose checkbox and then try again. We have added some additional log statements that may help indicate the issue. (v2.28.7)

Also, what path are you installing RoboRealm on?

Note the file size changes are misleading. The trial and commercial copy differed by the inclusion of an extra file. The two executables are very similar in size and do not differ in the plugin loading areas.

If the trial works, so should the commercial version ... but obviously that's not the case with you so something somewhere else may be incorrect.

quitana from Germany  [20 posts] 13 year
Hello Steven,

Tomorrow I'll make a video of the error and give it to you via FTP.

It's funny and maybe stupid: Could it have something to do with different country-specific Windows versions? Maybe stupid, but I have not found any machine on which it works and I am from Germany. You have no where it don't works and you are from the United States. Perhaps nonsense, but who knows.

OK tomorrow I will make a video and give you as much information as possible ....
Anonymous 13 year

That's what we are suspecting too. We're interested in the full path of the dll (now added to the log file) and if that contains any extended ASCII codes that are typical in non-English speaking countries. We noticed in a previous robofile that the comment contained one of those characters that caused an issue ... so we're thinking that this may be the cause.

What is really strange is to see that the trial works but not the commercial one! Not sure why there would be a difference there ...

Perhaps we will try getting access to a German version of the OS and add that into the test plan!

quitana from Germany  [20 posts] 13 year
Hi Steven,

I shot a video and put it on a ftp-server. You can use filezilla etc. to get the video.

I've send you the account data for the ftp-server via the contact formular (http://www.roborealm.com/contact.php).

Thanks for help.
Anonymous 13 year

I think we found the issue! It was actually related to the AVM plugin which differs from the Trial to the Commercial version.

Can you download 2.28.8 and give things a try?

Thanks for the video. That helped isolate the problem. When we see the errors and behavior in realtime that really helps to isolate the issue.

quitana from Germany  [20 posts] 13 year
Hi Steven,

thank you very much for great support!!! All works fine now - so the project really begin.I have two final questions. I do not know if I should open a new thread?

1) Is it possible to chance Image size in a DLL-Plugin? In the main image processing call "Process(...)" i get a pointer to the image data. If I would get  a pointer to a pointer, I could probably change the size . Are there other options?

Background is that we implement some things outside of RoboRealm, but we want to use RoboRealm at all because for us it is an easy to use development and test framework which in addition runs very stable at all. So we decided to use it actually in industrial environment for low cost applications.

2) Our client already has a RoboRealm license. They bought it before the license manager started (online validation). The system runs on a computer, which is not connected to the Internet. Is that a problem at all?

Thank you again for support.
Anonymous 13 year

1) Please download the most recent RR version 2.28.9 which has an update to support the dll plugin to resize the main RR image.

You will also need to download the Plugin.zip again from


and at least update the ModuleDlg.cpp/.h and the RRModule.cpp. It may also be a good idea to copy all other relevant files just so that you are using the most recent copies.

Once the plugin has these new changes you can use

Resize(400,400, &data, &tmp2Image, &tmpImage);

within the main process function to change the size of the image being used in RR. Note that data is preserved but the tmp images may lose their content. Also note that while data is preserved it is not aligned to the new specified size (i.e. cropped or enlarged).

Also note that you have to call this routine everytime the image is processed. This does not change the size/dimension of the original image loaded into RR before your plugin. Just those after it.

2) You can have them download the most recent copy, go through the installation and when run the app will provide them with a GUI dialog with a code that you can either use the following url to register or email it to us.


Thus you can perform the registration on a machine without having the internet running on that machine. But you will have to have access to a machine that does in order to register the code.

Let us know if you have any issues with the above.

Anonymous 13 year
Hi Steven,

Thank you very much for support!


This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index