Lego  RCX control interface
Tom from United States  [3 posts]
14 year
I am new to roborealm, and am trying out interfacing with some of my robot platforms. I have been generally sucessful except for the interface to the lego RCX. I have installed the phantom.dll and it works with the test progam that accompanies the driver but roborealm fails to recognize the dll. I have placed the dll in the roborealm folder but no luck. Any suggestions/
Anonymous 14 year

A while back we found an issue with the Phantom DLL provided with the link in the documentation page. This was corrected but placed along with RoboRealm's distribution. Try copying the Phantom.dll in the RoboRealm folder into the location that you installed Phantom.dll (most likely c:\windows\system32\) to overwrite the other dll.

Let me know if this still causes RoboRealm not to recognize that dll.

We'll update the documentation accordingly.

Tom from United States  [3 posts] 14 year
Still no luck. I tried reinstalling roborealm, and moving phantom.dll to sys32 folder but roborealm still can't seen to find phantom.
Anonymous 14 year

Windows Start Button->Run->Type in cmd

Then use

cd /windows/system32/

and then try

regsvr32 Phantom.dll

which should then tell windows where to find that dll.

Tom from United States  [3 posts] 13 year
Still no luck. I downloaded the most recent version of Roborealm. I transfered phantom.dll to system32 and registered it. Roborealm still refuses to recognize phantom. Phatom works with the phantom test program in the phatom folder.

This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index