Lynxmotion loses communication with roborealm
Loren John Presley from United States  [17 posts]
14 year
I'm having an issue with the lynxmotion SSC. It's been working for a while, but this evening when I powered up my robot, the lynxmotion communicated with Roborealm for only a split second (the servos began to move to their neutral positions) then the message came up that said something along the lines of, "Cannot interface lynxmotion at 115200 baud rate."

I checked the baud rate for the lynxmotion controller, and it was set to 9600. I don't know how that happened. Anyway, I reset it to 115200.

I powered up my robot...still same issue, even when it says in the device manager that the lynxmotion SSC is functioning properly and the baud rate is 115200 like it should be.

Again, I haven't had this issue before and I don't know how to fix it. Any pointers?

Thanks in advance.
Anonymous 14 year

Did anything to your knowledge can inbetween it working and not? Did you upgrade any software between that time?

Perhaps it is the servo batteries for the SSC? Are they powered up sufficiently? It is possible that without enough power the SSC is resetting and thus RR is complaining about a failed communication.

Loren John Presley from United States  [17 posts] 14 year
Okay, I checked all the connections, both batteries were fully charged (the battery for logic and the battery for servos). Still, the same thing happened.

Then I thought a moment, and decided to create a new robo file, this time eliminating all items in the pipeline except for the lynxmotion. It worked! The lynxmotion connected with roborealm at the right speed.

I'm wondering if it was because I had two many items in the pipeline. Is that possible?
Anonymous 14 year
The number of items in the pipeline should not have mattered. It is most likely something that was removed that caused the problem. Certainly if there was another serial module in the pipeline that may have been causing the issue but it may also have been much more subtle than that.

Does the old config now still not work? Or did it start operating correctly again? If it still does not work can you post it here so that we can test each module to see which one is causing the issue?

Nice job debugging!


This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index