Sabertooth 2X25, motors not responding
Loren John Presley from United States  [17 posts]
15 year
I'm not actually sure if this is a bug, but the motors on my robot are not responding. I've connected the Sabertooth 2x25, turned on the power (the blue led went on), and tried moving the motor sliders. But no go...

I've checked my electrical connections again and again, but everything seems to be in order...

I'm using a TTL USB cable (the kind that's used in the tutorial on interfacing roborealm to the Sabertooth). Upon insering the cable, it was detected by my computer and it downloaded the proper software...

apparently, roborealm knows the sabertooth is there too, because it shows up in the control > sabertooth window as a port.

I've also checked to make sure its the proper serial setting on the DIP switch on the sabertooth board. 1 and 2 are down, the rest are up. Is this correct?

Anyone know why my robot won't budge? I'll continue working on my end too.

Loren John Presley
Anonymous 15 year
I'm having the same problem.  I know my Sabertooth worked with a potentiometer but when trying to use packetized serial control.  It won't even budge.  2X25.  And I am using the roborealm software.
Loren John Presley from United States  [17 posts] 15 year
Okay, I got it to work.

Here's what I did:

I went to Control Pannel > System > Hardware > Device manager > found the USB to TTL port, and made sure the baud rates were the same.

Afterward I went back to roborealm, flipped the switch to turn on the sabertooth, then made sure I selected the corresponding set baud rate with the Sabertooth window. The message popped up saying I needed to recycle power through the sabertooth, which I closed. Then WITHOUT recycling power through the sabertooth I moved the slider for motor 2 and it spins!

Now if I can just get motor 1 to spin as well...I hear a tiny click/budge from it when I adjust the slider, but that's all...hmm...maybe it the motor itself. I hope not. I'll try to fix it, but in any case, I got the Sabertooth to communicate.


This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index