video capture from source crash
John from United States  [5 posts]
17 year
When trying to save to Write AVI, RR crashes.

RR works when I set 'Image to Save' to Current, but it only crashes if I set it to Source. The Current setting seems to give low quality, so I would perfer to use Source . . .

No other settings seem to have any effect on crashing.
Anonymous 17 year

Not sure on the error that you are seeing (we will try to replicate and fix). However, in your case the Source and Current are probably the same image unless you have some filters in the processing pipeline before you are saving to AVI. Instead, you probably want to experiment around with the Codecs as they will dictate the overall quality of the video.

John from United States  [5 posts] 17 year
I tried Harris_Corners and Pseudo_Color, both with the same result.

I tried several codecs, but thats not the reason for the low quality. The processing for Current is jumpy, so when my computer gets bogged down during capture, the output video is really jumpy, too.
Jumpy video
17 year

Yes, that would be the situation where your CPU just cannot keep up with processing and recording at the same time. We had similar issues on our BucketBot robot ... which lead to our development of the Distributor client and server system. This allowed us to offload the video recording to another base computer that was more capable of keeping up. Thus it is possible to use more than one computer in an effort to keep the video smooth.

The recording capability is very much WYSIWYG ... i.e. if you see the video being jumpy due to CPU issues then the recording will exhibit the same behavior.

Or ... we recommend the new Intel dual core systems ... but that requires a little more investment!

John from United States  [5 posts] 17 year
I have an Intel Core Duo running at 1.8Ghz, 256mb ATI vid card, and 1gb ram. I dont think my laptop is the problem . . . =P

Anyway, I dont need to do real-time processing. I want to just read from a saved Source video file - something that doesnt require super high speed processing. But when I do that, RR simply crashes. This isnt a problem with my processor, but with a flaw in the RR software. =P

This is the problem I am looking to get fixed.


This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index