Read_HTTP and Linksys WVC54GCA IP camera
from United States  [214 posts]
14 year
Hi STeven,

I just picked up a wireless Linksys WVC54GCA IP camera.  The URL to the motion jpeg works fine if I just copy and paste it into my browser's location box:

But when I use the same URL in the RoboRealm Read_HTTP module, I do not see an image after clicking the Start button (Refresh is set to ASAP).  I have the same problem with or without authentication.

One clue is that the above URL causes the web browser (Firefox) to continually refresh.  If I click the "Stop" button on the browser, I get the error message:

The image "" cannot be displayed because it contains errors.

Occasionally however, I can get the image to freeze this way and then a "View Page Source" shows the following lines at the top of the binary image data:

Content-type: image/jpeg
Content-Length: 8374

I tried copying these into the RoboRealm "Additional HTTP Headers" box in the Read_HTTP module, but that didn't fix it.

Do you have any suggestions how I might find the right URL to work with RoboRealm?  Or perhaps the right additional HTTP headers?


Anonymous 14 year

We found another same model camera at


but their url is


Nevertheless, there was a small problem even with this one that caused RR to not grab the image correctly. This has been fixed and uploaded in Can you try to redownload and see if this helps your situation?

from United States  [214 posts] 14 year
Hi STeven,

You guys rock!  I had tried that alternate form of the URL earlier without success but now with RR it works perfectly.

Many thanks!

from United States  [214 posts] 14 year
Hi STeven,

I'm back to playing with the Linksys WVC54GCA wireless IP  camera and the Read_HTTP module in RR  The trouble I am having is slow frame rates in RoboRealm even without any processing.  The video looks smooth and fast in both IE and Firefox, but the best I can get in RoboRealm running on the same computer is about 7 fps.

I set up the Linksys camera for Normal quality and 30 fps max at 320x240 resolution for both MPEG-4 and MJPEG.  If I view the video within the Linksys web-based application, the motion looks smooth and fast--but this uses some javascript code to display the video (see below).  The URL I am using in RR is and even with the Refresh Frequency set to ASAP, the fastest frame rate I see is 7 fps and the video is noticeably slower than when viewing through the Linksys interface.

Do you have any suggestions on how I can get a better refresh rate in RR?


P.S.  Here is the relevant piece of javascript when doing a "view source" in the Linksys web based viewer:

var dw_jpeg =     '<object classid="clsid:7B133798-FAA8-4A7e-950D-BEB35D3363AF" CODEBASE="LinksysViewer.cab#Version=2,0,0,16" id="LinksysViewer" width="640" height="524">'+
                  '<param name="Text" value="http://'+
                  ' '+
                  ' '+
                  '">' +
                  '<param name="BackColor" value="12632256">'+
                  '<param name="_Version" value="65536">'+
                  '<param name="_ExtentX" value="11774">'+
                  '<param name="_ExtentY" value="6562">'+

Anonymous from United Kingdom  [99 posts] 14 year
Something quick to try:  I have noticed that when I set the frame rate to 30 in roborealm recently, (on a variety of networked cameras) the pipeline slows down to about 7fps.(This didn't happen on older versions (from about 3 months ago or so.)  Try setting the framerate in roborealm to 20 fps and see if things improve.  At the 20fps I indeed get 20 fps.  It works for me but I have no idea why?  (Buffer issues or ??)

good luck!
from United States  [214 posts] 14 year
Thanks profmason.  Unfortunately that did not fix my problem.  I also tried every possible speed, quality and resolution setting on the Linksys control panel with no luck--RoboRealm always seems to get the video stream at around 7 fps or less.

I found a nice test application at:


that can point to various webcam URLs.  I tried it on my Linksys video stream and it works great--about 17 frames per second with the Linksys set at Normal quality, 320x240 resolution and 30 fps.  So it looks like there might be a problem with the way RoboRealm is getting the stream.  The URL to the Linksys I am using is:

(Of course that will work only my local network!)


Anonymous 14 year

We did find an issue with that particular camera. Seems that it checks the browser type before sending images back. We tweaked the parameters that get sent to the camera that have significantly improved the speed (at least in our tests). Can you download and try the latest version

from United States  [214 posts] 14 year
Thank you STeven!  Works beautifully now--a full 30 frames per second at 320x240!


This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index