Firewire Camcorder Support
Danh from United States  [79 posts]
15 year

Anothe future feature request: Could you'll investigate supporting CAMcorders with firewire?

I've tried two different brand CAMcorders under WinXp with their firewire interface. WinXP automatically recognizes the CAMcorders and the images can be previewed under Scanners and Camera in My Computer. Images are very crisp even under motion.

In the RoboRealm drop down menus the CAMcorders show up as "Microsoft DV CAmera and VCR" but when trying to connect I get an error message that says "Only RGB24, RGB32, RGB555, YUV, YUY2, UYVY, I420, IYUV, YV12, Y800 image formats are supported!No driver found for dvsd"

SplitCAM and ManyCAM (another virtual cam driver) can display the images. SplitCAM goes a step further by deinterlacing the image(menu option) so that horizontal lines during motion are removed.

VidCap32 won't connect properly. Another program called AmCap will connect but there are terrible horizontal lines due to interlacing.

For now I'm just using SplitCAM but it's burning up 40% of my CPU for some reason.

From an application standpoint I found that a camcorder has really good image quality and the 30x - 35x optical focus is necessary in order for me to recognize objects from a distance.

For around $200 it's hard to beat the price to performance ratio of a firewire camcorder.


Anonymous 15 year

You appear to be missing the dvsd driver. We've seen this issue many times before. You can download the driver at


and click on the


file to download and install. The driver provides a directX interface to the dvsd format which is apparently what RR is complaining about. Try downloading and installing this and see if that helps any.

Note that RR has a de-interlacing module if you need it.

Danh from United States  [79 posts] 15 year

I tried running the .exe but I got a nasty error message "Error reading setup initialization file" in a dialog box with a button containing no text. See attached image.

Is it correct that the other programs I'm using to view the Camcorder image (SplitCam, ManyCam, Matlab) are probably using something like VFW instead of DirectX?

I'll try out the deinterlacing module by capturing the Camcorder video with ManyCam and then by piping it into RoboRealm for processing.

Danh from United States  [79 posts] 15 year
forgot to include the error dialog box from the dv codec executable file referenced above. Now attached:
Nick from United States  [1 posts] 15 year
ya i have the same problem. same error too.
Charlie from United States  [1 posts] 15 year
Has anyone figured this problem out?  I'm having it as well.

I installed the CMU driver, as suggested, to try to access the feed from my ADVC-55 firewire analog video input (Processing accesses the video stream perfectly.)


This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index