communicating to nxt over usb, and variables?
15 year
hey again, my bot is stationary, I would like to use usb, but I also have a program running on my nxt that controls precise motor movements, and activates when a message is sent from the vb script module, is there any way to get this to work over usb instead of bluetooth, as it cuts out for me often.

or an alternative way?
Anonymous 15 year
also, RR gives me an error and crashes whenever I switch to usb in the lego nxt module... :(
Anonymous 15 year
is the usb crash a known issue or some issue of my configuration?
Anonymous 15 year
We tried to replicate your issue without success. It appears that sending messages via mailboxes when connected via USB had been fixed a long time ago but the documentation was just never updated. This documentation change has been fixed.

Now onto your issue: Have you tried from a New blank RR pipeline and then insert a Lego_NXT module and select the USB from the connection dropdown? I just verified that the lego example #2 on


does work over USB mode. You should be able to just move the motor scroll bar and have the motors move just to verify the USB connection works. We've found it to be much more reliable than the bluetooth and always use the USB mode if possible.

Perhaps you also can attach your robofile as something else might be affecting the Lego_NXT module that we are unaware of.

Anonymous 15 year
okay, I just reinstalled a fresh copy of windows, the lego nxt software, and robo realm...

now I can set usb, it tells me com port 1 cannot be intialized, then if change the motors around nothing happens.  If I touch the connection setting again, it crashes and gives me an error report.

I am running RR on a macbook pro running windows sp 2 with the original firmware in the nxt, should I update that?

Also my computer has a built in isight usb camera and I have a lego camera attached, just wondering if all that usb could be causing some kind of conflict...

theres nothing in my robo file but the nxt module.

I can send you anything, but thanks so much for the quick support you give, it's seriously amazing.
Anonymous 15 year
just some more info:

I disabled the other camera, then all usb, including the nxt, and RR still crashes when it lego nxt module is set to usb,

my NXT already came with the newest drivers and firmware apparently.

This is strange with a fresh copy of windows.
Anonymous 15 year
If I uninstall the nxt driver totally then RR does not crash, but instructs me to install a new version of fantom.dll.

I believe I am using a new version of the nxt, version 1.1 software, 1.05 firmware and a driver newer than the one available on their website, 1.02.

I am sorry to post so many times, but I'm hopeful some of this information will be helpful?
Anonymous 15 year
I went back to an older version of RR, I think, running on a virtual machine using the same exact operating system and USB worked fine, and FAST, then I upgraded to version on that virtual machine and now I get the same problem from RR that I got in and 4

something to do with the updates?
Anonymous 15 year
Yes, your last message definately hit the nail. The most recent versions underwent an optimization that seems to have removed some failsafes that had caused the fantom.dll NOT to crash when we were calling it incorrectly. Once these were removed it naturally started to crash. This information allowed us to replicate the error and we have now uploaded a fix in Please download the latest version and try once more.

Thanks for your patience in this .. your messages really helped to narrow down the issue and get a fix up quickly.

Anonymous 15 year
Can I donate to you guys yet?
Anonymous 15 year
Not just yet ... but thanks very much for the offer!!


This forum thread has been closed due to inactivity (more than 4 months) or number of replies (more than 50 messages). Please start a New Post and enter a new forum thread with the appropriate title.

 New Post   Forum Index